Write protected issue & formatted wrong size

I’m using my Sandisk 64GB memory card in my dashcam. A notification came up on the screen to say the memory card is full which surprised me because it’s supposed to write over older files.

I put the card in my PC and realised that I had formatted it in FAT32, therefore, it was only using 32GB. I tried reformatting it in NTFS and then any format because it kept stating the card is write protected even though it appears not be.

I tried deleting files which seemed successful but they didn’t delete!

I’ve used diskpart to change any write protected attributes and format the card to no avail as the latter comes up with an unknown error message. In Disk Management the unallocated space is seen but can’t do anything with that software either.

Why isn’t it working or what else can I do to wipe clean the card and begin again?

Thanks very much.

Hi @Klepto,

Please check the below-mentioned link to understand more about the issue:

Title: SD/SDHC/SDXC memory card is write-protected or locked
https://kb.sandisk.com/app/answers/detail/a_id/1102

Title: SanDisk microSD memory card is write-protected or locked
https://kb.sandisk.com/app/answers/detail/a_id/6971

NOTE: If using a company computer, ensure your IT department does not block saving files to removable cards.