won't reset, start or get recognized by PC after microSD


My sansa clip zip 8GB works/worked fine, as long as I don’t insert a microSD. I tried it with two different ones, the first one was a sandisk 8GB (probably class 4, can’t remember. An older one), the second one that I have here is a kingston 16GB class 4.

When I insert a microSD, it refreshes but doesn’t start again and won’t react to the start button. I managed to reset it (or force it to MSC mode, like in the support pages) with the microSD card not inserted. 

I did the firmware update just now, inserted the microSD card again, same problem but now it won’t even reset ( microSD not inserted any more!) and it doesn’t get recognised by the PC (not with windows 7 and not with linux mint).

There is a unknown device showing up in my device manager with a “!”, but it won’t find a driver via the internet nor on my PC (I guess, the firmware update is NOT the driver? When I search for a driver on the support pages, it just tells me about the firmware update.)  -> turned out to be something else, not related to the clip zip

What else can I do? I don’t necessarily need the microSD, I just want to make the player itself work again.

Now, this is strange. I plugged the clip zip into the socket, just to experiment further - and suddenly it reacted to the start button and everything is fine again??

I tried to turn it on without a cable attached, but that didn’t work, but plugged to the socket, it suddenly did. Strange, but fine.

Well, at least, maybe this helps others. It didn’t solve the problem with the microSD, but at least the player itself works again.

Only insert or remove a card when the player is off. The Clip Zip  has issues with cards faster than class 4.

@jk98 wrote:

The Clip Zip  has issues with cards faster than class 4.

Sometimes yes, sometimes no–seems to be card dependent.