wont even show logo, screen completely blank Please HELP!! (have tried SD micro chip)

My sansa screen is completely blank.  It dont even show two second sandisk logo when I push power button.  I tried putting a SD micro chip in and pressing power and still blank.

I have debricked it twice since I have owned it with SD micro and it worked.

What happened was My sansa was charging on a computer with XP (I have never used this computer to charge it).  The battery was very empty.  It was showing its normal “charging” message on the screen, but when I came back the sansa screen was blank.

Shows nothing in “my computer” and nothing in device manager under removable storage or another catagory.

(also tried hard and soft reset and hard reset 5 times like some suggested in another forum)

Please help me fix it.  Anything appreciated!!

Message Edited by needhelp2 on 07-05-2008 02:20 PM

Message Edited by needhelp2 on 07-05-2008 03:37 PM

Phone Sandisk first. They will help you faster than if you asked here.