Won't connect to IOS 8.3

My drive will connected and immediately disconnect. It worked yesterday. ???any suggestions? I tried upgrading the firmware and it hasn’t worked since.


It could be a wifi channel conflict. try changing the WFD wifi channel. 


I just solved this by myself on my Iphone 5 IOS 8.3. It took me over an hour to find out!

  1. Make sure the Wireless Flash app is close. 2. Go to Setting then Wi-Fi

  2. Pick your Sandisk wifi name then connect to it

  3. Once you got it connecting stay where you are then find the big “i” icon next to the singnal bar right of your Sandisk wifi name

  4. Write down the Subnet Mask number you see e.g

  5. Write down the Router number e.g 134.443.0.1

  6. Open Safari then type on the address bar the subnet number wrote then click Go, let it liad for a while about 20 sec

  7. Then stop the loading then replace the subnet number with the Router number then click Go.

  8. Now you should connect to your Sandisk wireless flash drive via Safari

  9. Try to browse a pdf file or something

  10. Open your Wireless Flash app

  11. Hopefully the magic comes true!