WMP11 crashes when Sansa Fuze is connected

My wife got me the 4GB Sansa Fuze for Christmas. When I attempted to synic it with WMP, WMP crashes. In fact it crashes when ever the Fuze is connected. When it is not connected WMP11 works fine, all my music and play lists are there but as soon as the Fuze is reconginized by Windows, WMP11 closes or out right crashes. I can get to the Fuze through Explorer with no problems, it also charges and I can drag-n-drop files to it.

I have Real Player v10 installed but don’t use it for music. I have unistalled and reinstalled WMP11 but it didn’t fix the problem. I’ve found similar posts concerning WMP11 but they didn’t offer any help.

I’m running:

Windows XP Pro SP3 - up to date

WMP11 - up to date

Sansa Fuze firmware version: 02.02.26A, USB Mode: Auto Detect, but the problem still occures in MTP & MSC.

Any help is greatly appreciated. If I missed the solution in my search please point me in the right direction.


if this is happening even in MSC mode do other MSC devices (i.e. Flash Drives, External hard drives, memory card reader) also trigger the crash as well?


Just tested that with a Lexar 128MB Jumpdrive.  WMP11 crashed when I plugged it in.  After clearing the crash report message, I tried to open WMP again and it immediately closed.

Short answer: Yes, same results as when the Fuze is plugged in.

Just for kicks I also tried my Palm Z22 and it did not affect WMP; however, the HotSync conduit is only operational if the palm desktop program is running.

I captured the top lines of the exception information from the crash, is there something in the detail I should look for? 

AppName: wmplayer.exe     AppVer: 11.0.5721.5145     ModName: indiv01.key
ModVer: 11.0.6000.7000     Offset: 000ab5d6

I’m running WiMP11 build 11.0.5721.5268 on this machine, slightly different perhaps.  Have a look at this series of posts from Tech Arena.  The posts follow a nested format, but the nuts and bolts are there if you scroll through them.

Looks like they found an issue with the DRM store.  The common issue looks like a WiMP11 crash when a flash drive is plugged in.  Let me know if it helps!

In a linked page, there’s talk of conflicts with arlier codecs installed- I haven’t run into this, with CCCP installed.  In fact, CCCP’s codec bundle improved performance, as I can view chapter data when a DVD is mounted.  Before it, DVDs would not play properly.

Bob  :smileyvery-happy:


Thanks the Tech Arena post it helped to solve the problem. I’ve been able to sync with WMP11. :smileyvery-happy:

Still had problems with it though. The DRM directory would not show itself, even with the folder options set to show hidden and system files. The only way I could see it was through the command prompt using “dir /A” but I still couldn’t delete the directory. Kept getting file not found erros. I had to boot my PC using a Mepis 8 Linux LiveCD. Only then was I able to delete the directory. After rebooting back into XP I was finally able to run the Individualisation to reset the DRM.

I have experienced the same problem with sansa clip+. Have recently had computer rebuild with new m/board, etc. Have located the DRM file. Is it safe to delete everything in it. Should I copy it first. Will deleting the file effect my music in WMP 11.

Would appreciate your help as this is all new to me



From what what understand from Tech Arena posts neutron_bod pointed me to, is that the DRM directory can become corrupted after a rebuild.  I put in a new mother board over a year ago but never noticed the problem until my wife got me my Fuze.  

Deleting the directory was the only way that would allow me to run the Individualisation and fix the problem.  It did not seem to affect anything that I could see and my music was safe–however all my music is DRM free.

If you have any music that has DRM/usage rights, you will need to download those usage rights again after re-Individualing WMP.  The WMP FAQ has a DRM section that talks about this.



Thanks for your reply. I followed the link you supplied but when I clicked on ‘technical information’, WMP closed.

Which folder do I delete in DRM, is it the cache?

How can I determine whether my music on WMP is DRM free. I don’t download any, just rip from my CD’s.

I’m not sure now whether this problem is worth fixing, if it’s not going to effect anything else. 

You guy’s seem to know what you are talking about, where as I feel a little out my depth here, but if you have any more advice, I would be grateful.

Thanks, db46


@db46 wrote:


I followed the link you supplied but when I clicked on ‘technical information’, WMP closed.

I was having this same problem–among others.

What I ended up doing was deleting the folder named DRM and everything in it including the cache folder. Then from the Run dialog box I put in:

%SystemRoot%\inf\unregmp2.exe /PerformIndiv

and hit enter. This fixed the problem and my Fuze was able to sync with WMP.  All my music and play lists survived intact.

The music I have was either ripped from CDs or purchased online without DRM.  Sorry, but I don’t know how to check to see if a song has DRM or not–although my wife says if it plays well after you rip it, it probably does not have DRM.

Fixing this problem was definitely worth it to me since I wanted to sync my Fuze with WMP.  If you can sync your clip+ with another program without WMP interfering (i.e. causing it to crash), then that might be a work around for you.  But if you had everything in WMP to begin with, redoing it in a different program is a disadvantage to fixing the problem.

Hope this helps.


Hey Deiter,

I really appreciate your help. I am going to pluck up courage to give it a go, so I’ll let you know the result.

I am new to these forums, but they have proved their worth already. When I bought my clip+ last week, I downloaded the updater but after updating my files, I found it had reduced the volume. It was only when reading thro. the questions that I found the answer. Reset to ‘worldwide’ and reset defaults, and it worked!

So I do appreciate all you techies out there trying to help,

Regards, db46


Finally cleared DRM folder, all OK. I didn’t run ‘%SystemRoot%\inf\unregmp2.exe/PerformIndiv’, tho, What is that supposed to do?

Thanks for help, appreciate it