windows xp sp-3 wont recognize sansa fuse+ in mtp mode nor will rhapsody

when i plug the sansa fuse

  • into the usb port it says new hardware found .then when window wizard trys to locatte from hardware manager it errors with specified service does not exsist as an installed service ive tryed new drivers, but get the same answer. rhapsody says about the sansa fuse+ that it needs to be configured . i bought the sansa player because it was on their list of compatable players for downloading   subscription tracks .as i said before the msc mode works fine on both windows media plyer and rhapsody . some techs i talked to said i might have to reload windows xp again , because it might not be  avalid copy . also i might have to roll back windows media player which is nearly impossable. can you please give the answer to this prblem so that i might be able to enjoy downloading subscription tracks from rhapsody            Thank You for Your Time. Sincerly Ken Kretzmer {}

I assume you’re using windows media Player 10 or 11? If that is the case, try reinstalling whichever version you have (if you don’t know, install 11). If you don’t have 10 or 11 try installing 11 and see if that helps.

First and foremost, you need MTP Capability on your PC.  This incorporates the WMDRM-10 or Janus DRM system into your operating system.  There are two possible routes, both available as free updates from Microsoft.

Windows XP has been around for a long time in computer terms.  Long enough, in fact, that it predates MTP.  Windows XP was shipped without MTP capability as Windows Media Player 10 or later is needed to give you MTP capability.  Windows XP was bundled with Windows Media Player 9.

There are two possible routes to update to WiMP10.  If the player is open, click on Help > About and you can verify your media player version.  Also, under Help go to > Check For Updates, and you should be directed to Microsoft’s web site for Windows Media Player 10.

You can also type Windows Media Player into your favorite search engine and then look for the player from Microsoft’s site.  Yes, WiMP 11 is also available, and I prefer it to 10, ass the interface is a bit nicer.

First, upgrade to Windows Media Player 10 / 11.  Afterwards, your Sansa should commect in MTP mode automatically once plugged in.  Test this by opening a Windows Explorer window via My Computer,  You will see the Sansa listed at the bottom as a media device, described in “caps and smalls” as Sansa Fuze+.  If it shows up as a flassh drive with a letter assigned, as E: SANSA FUZEP, it is connected in MSC mode.

Note, barring any other changes to the Fuze Plus’ settings, it should connect automatically in MTP mode.  If it did not, there is one detail we must address at this point.  The Fuze has a function known as Auto Detect, where it will connect in MTP if available, otherwise it will switch to MSC.  This function helped you establish a connection, though Rhapsody wants MTP for subscription media, which is key to the service.  Without the automatic function, the Fuze wouldn’t connect at all, since you didn’t have MTP capability.  This is why the function exists.

That being said, if you have installed Windows Media Player 10 / 11 and the Sansa is still not recognized, unplug the device and check its setting for connection, going to Settings > System Settings > USB Mode and you can manually set MSC or MTP.

One last thing is the MTP Porting Kit also available from Microsoft.  This can also be installed, but I’ll bet that once you update the Windows Media Player version you should be good to go.

Take it one step at a time, and we should be in business!  Don’t hesitate to ask any questions here, including feedback if all is well!  Once you have MTP mode, you can open the Rhapsody application, and the Fuze+ will show up as it does in My Computer, listed in caps and smalls as Sansa Fuze+.

Right click on the Fuze in the Rhapsody Sources pane on the left, and select authorize.  Then go crazy in the Music Guide and drag your favorite songs and albums to the Fuze.

Bob  :stuck_out_tongue:

Thanks!  I was having the same problem and updating to the latest Windows Media player did the trick!