Windows Popup Error when I plug my Express to the PC

Hello everybody,

I’m a new Sansa Express owner (just got it yesterday). After a few problems I was able to update the firmware from the original 01.00.15A2 to the latest 01.01.05A

But this is not what I’m here to ask about. The problem is that everytime I connect the Express to my PC’s USB socket, a popup window shows up with the following text:

Windows - Disk not present

(X) Exception Processing Message c0000013 Parameters 75b1bf9c 75b1bf9c 75b1bf9c

[Retry]   [Continue]   [Cancel]

If I hit ‘retry’ or ‘cancel’ the popup simply show up again.

If I click on ‘continue’, the Express mounts and it seems to work fine.

But why does this error show up, and how can I get rid of it?

Thanks for your help


It sounds to me like Windows is having a hard time because it’s seeing the card slot on the player and trying to access it as though there were a disk inserted.  Unless you have a disk in the slot, this shouldn’t ever be an issue, but it sounds like a problem with the computer.

Does the Express show up in My Computer as a Removable Disk or as a Portable Device?  If you aren’t sure, check and see if it has a drive letter (for example, the name will end with a letter and a colon, like “E:”) and if it does, it’s a Removable Disk.

Yes, it shows as a removable disk.
A friend of mine suggested to upgrade to WMP11 (I don’t use WMP, so I never upgraded) because he says that if I let Windows manage the Express through the MTP protocol that error should disappear. I could try, although I’d rather use my player as MSC.;en-us;330137

This could be relevant.

Other than that, have you tried uninstalling and reinstalling the Express under Device Manager?  Just right-click and ‘Uninstall’ then reconnect it.  If you don’t see anything labelled Sansa Express in the Device Manager, look for a USB Mass Storage Device.

Hi kennyj, thanks for the suggestion, although it’s not the same error, nor it can be, considering the different scenarios.
I upgraded WMP to v11 and the error stopped showing, though.
So I guess the error is linked to MTP or something…