Windows Media Player automatic playback

Does anyone know how to stop Windows Media Player (v11) from automatically playing CDs when I insert them?  I have set WMP Options-File Types so that WMP is not the default player for any file type.  I have done the same in Control Panel/Explorer Folder Options-File Types.  In Explorer, I have set the CD drive AutoPlay options to “Take No Action” for all file types.  In TweakUI AutoPlay-Drives, I have turned off AutoPlay for all drive letters, and in TweakUI AutoPlay-Types I have turned off Enable AutoPlay for both options (CD/DVD and removable).  I have even re-booted since making all these changes and still WMP starts playing the disk when I put it in, even though I don’t want to play it, I just want to rip it.

Thanks.