windows 8.1 no longer recognize any fuze but they work fine with windows 10

Hi;  I have several fuzes and cords.  I have put music and audio books on them on my desktop running windows 8.1.  Before a couple of months ago everything worked fine.  Now the computer doesn’t recognize any of them using any of the cords.  It isn’t a problem with the fuzes or the cords as I checked them with a laptop running windows 10 and all worked. 

  On the windows 8.1 desktop If I put it in msc mode it is recognized,  not mtp mode.  That would be fine but it shows all the interal folders as empty.  I have tried all the usb ports on desktop and monitor.  By going to the device manager I get 

This device is not configured correctly. (Code 1)

A service installation section in this INF is invalid.

To find a driver for this device, click Update Driver.

Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

I uninstalled the driver, disconnected, then reconected.  Still no go.  All I can think is maybe it is due to some windows 8.1 update.  On an old computer an update made my cd drive stop working.  They weren’t compatible.  I was wondering if anyone else has had this problem?  If so were you able to fix it?  Thanks.

I went and uninstalled all windows 8.1 updates for the past 3 months  (about 7 of them).  I did all of them at once so I don’t know which one was the culprit, but the computer now recognizes all my fuzes.  It was a windows  8.1 update issue.  If they are later put back on I will try to find the culprit and post it here.

Thanks for your diligence and follow-up!