Windows 10 won't boot when using SATA 3 port

I’m using the Ultra II 240GB drive.  I originally installed the drive into a SATA 2 port and cloned my 1 TB drive which contained windows 10 - 32 bit, everything worked fine.  I then relinstalled windows 10 - 64 bit and again everything worked fine.  The Sandisk dashboard showed I was only connected at 3 GBps, so I switched SSD drive to the only SATA 3.0 port and moved the 1 TB seagate drive to the SATA 2.0 port.  I booted the system making sure the boot sequence was correct with the SSD booting first, but windows nevers starts.  I see the Lenovo splash screen then the computer shuts down.  

I have a Lenovo M82 tower computer.


I believe swapping ports on the same controller shouldn’t matter. Please provide the following to let me see what I can find out:

  • If you change the boot sequence with HDD booting first leaving it connected to the SATA-II port, Does the Computer boot? 

  • exact model of the Lenovo M82 series or the model of motherboard?

Thank you!