Winamp & your Sansa Device (Auto Terminate / Crash) ~~PART 2~~ possible fix!

Earlier I wrote a thread about this issue and a solve for it, you can view it here. and suggested that the only option to fixing this was to remove MTP usablility with winamp and completely disable the feature.

I came across something interesting. For those who would like to get your sansa working with Winamp I have for you a possible fix. Try uninstalling WMP11 (and runtime) and installing WMP10.

Then you should have the latest version of winamp and also an important component installed. The portable media support that winamp provides.

The reason why I think this may work is because the MTP drivers provided by WMP11 vs WMP10 are different in the way of how the player works with your PC. Although WMP10 is limited in features with explorer, the drivers seem to allow for more versitility (like stripping DRM content and now winamp usability). Anyways I did test winamp with WMP11 and WMP10 with my fuze and clip. with WMP11 winamp would just unexpectively terminate as soon as my players were connected, but WMP10 it didn’t close! I was able to transfer song, browse through the player with the winamp library. So now I want everyone to try this out, for those who’ve had problems with winamp and their sansa players, or for those wanting to try winamp but never did. And please post comments and further issues! I will continue to work with winamp and offer support.

Message Edited by thoma on 05-29-2008 09:39 AM

Message Edited by thoma on 05-29-2008 09:55 AM

WinAmp doesn’t transfer album art properly under WMP 10, and MTP devices don’t show up correctly most of the time. I switched back because of that problem.

that’s correct, and its because Winamp doesn’t really handle album art. I’m not saying the feature isn’t there, you can view album art if you view tag info, or download a plug in to have an album art viewer, but the core program itself I don’t think was meant to handle album art so I think it won’t handle album art correct. Were you able to get album art working with WMP11 drivers and Winamp?

Message Edited by thoma on 05-29-2008 10:11 AM

It does handle album art under WMP11, not 10. When I had that godawful View I was able to transfer album art with WinAmp, but only under 11. 10 doesn’t allow it for whatever reason, and album art’s a big thing for me so I learned to suck it up and I’m using WMP11 for transfers.

@thoma wrote:
that’s correct, and its because Winamp doesn’t really handle album art. I’m not saying the feature isn’t there, you can view album art if you view tag info, or download a plug in to have an album art viewer, but the core program itself I don’t think was meant to handle album art so I think it won’t handle album art correct. Were you able to get album art working with WMP11 drivers and Winamp?
Message Edited by thoma on 05-29-2008 10:11 AM

Actually, Album Art support is pretty good in the latest version.  Big step up from previous versions where, as you said, album art was pretty much an after thought.  You can even sync album art in both MSC (copies folder.jpg) and MTP modes and there is pretty nice support integrated in the UI now (with the new Bento skin).  But there are still some gaps.  For example, if you transcode a file, embeded album art won’t carry over into the transcoded file.  But in general it’s quite decent.

This worked perfectly! Thanks so much.

Note, I uninstalled Windows Media player 11 and it rolled back to Windows media 9. 

This did not work.

When I specifically installed Windows media player 10 it worked.

Thanks again!