Win!0 Hanging on Shutdown

I got an ExtremePro 480 for my ThinkPad Yoga 12 laptop (i7 4500U) and I cloned the original LiteOn 250 SSD.

Now my Win!0 installation is hanging on shutdown when i use the system for more than an hour. It does shutdown Windows, I get a black screen and no visible or audible activity, but the computer doesn’t shut down and I’m forced to do a hard shutdown (holding the switch down for 10 sec’s). When I use the system for less than an hour or so, there is no problem.

The same problem occurs if the system is set to sleep.

I’ve tried with <shutdown.exe /s /f /t 00> but no change.

System Restart works OK though.

I’ve tried changing the Cache flush in disk properties, but no change.

I don’t see any Event Log entry that I can tie to the problem

Anybody got an idea?

Does windows 10 still have HIPM? I know this caused problems with some computers back in windows 7. if windows 10 has it you may want to try disabeling HIPM. 

Thanks for replying.

I have now found out what was causing the problem and it’s not related to the disk but to Windows 10 update and the Intel Management Engine Interface Driver. i rolled back the driver to an earlier version and now the system works fine.

Thanks anyway :smiley: