Will ReadyCache have a driver for Windows 10?

RedCache wrote:

@edd33, A clean install creates a different issue. The software doesn’t recognize the RC drive so can’t install. Myself and probably one or more people experienced this. 




The ExpressCache software looks for the ReadyCache drive in the registry. Can you check your registry and see if you see this entry?




ExpressCache is looking for one of the two following sub strings:





Here is the registry on Windows 10 (item 5):

RC Reg.jpg

Just wanted to updated users that are waiting on the Windows 10 update tool. The Windows 10 update fix is currently in qualification. We still expect to release by the end of the month. 

Forum Admin


Checked registry.

“services” under “current control set” isn’t there.

Searched for SANDISK_SDSSDRC - not found.

Searched for  VEN_SANDISK&PROD_SDSSDRC -  found under device instance: value data: SCSI\Disk&Ven_SanDisk&Prod_SDSSDRC032G\4&239d8b02&0&020000

found in HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\DeviceClasses{53f56307-b6bf-11d0-94f2-00a0c91efb8b}

Correction: The initial sequence found under currentcontrolset001. screen shot included.

Can you try copying that key to the following directy and let us know if you can then install ExpressCache?


hi RedCache,

Under current control set you should have a services folder. This is pretty standard however this is likely why the ExpressCache software is not seeing the ReadyCache SSD. 

Can you confirm that this is a full Windows 10 clean install? Would you be willing to export _HKEY_LOCAL_MACHINE\SYSTEM_? I can share it with our development team and see if we can find what the issue is with your system. 

Forums Admin



–This is a clean install. Harddrive formatted, partitions changed during the process. All files deleted.

–Rechecked registry. Now currentcontrolset has the keys that weren’t there yesterday. So, under disk>enum its identical to controlset001.

–Tried to install EC again. Got the same error - drive not found.

–Sandisk is sloppy and unprofessional. I’m not comfortable sharing reg data. 


  1. Yesterday you posted wrong information about your registry.

  2. Also, looking more closely at the registry key value that you sent, it shows:


“SCSI\Disk&Ven_SanDis_&…” instead of “SCSI\Disk&Ven_SanDisk…”

–> your drive is not found because you have the wrong registry value or the wrong device.

  1. Giving more registry information will not help resolve your issue.

    Windows does not register your device with the right registry information.

Are you using a genuine SanDisk drive?


:S Its the same drive. As real as it was before.

Good find. Checked again. The K in sandisk is missing in both currentcontrolset and controlset001.

Should I test adding the K back in?

Well, Windows is adding this key to the registry and I am not sure why it is wrong.

 You can try to change the value manually and the installer may find your drive, but you may have additional issues if Windows continues to write the key with the wrong value.

Let me know how it worked.

lol its not going to work is it. heh.

I’m about to try it out right now.


EC now installed after putting the K back in.

Cache is filling up. I’ll give it a day or two until I can figure out

if its actually working.

Any ideas why windows registry screwed up?

Any guesses if the fix will be reversed by windows?

(That’s all it took to troubleshoot for now? No offense. But it could have been done earlier/quicker. This is the reason why sandisk and support gets labeled sloppy. No offense to you. Thanks for helping out. Thanks to others too. But sloppy, dude.)

Make sure the key looks like this:

SCSI\ Disk&Ven_SanDisk&Prod _SDSSDRC032G\xxxxxxxxxxxxxxxxxxxx

And yes it should work if the key is not changed.

After installing and rebooting, take a look at the key again.

The K is gone.

The fix was reversed.

But did a cold boot.

EC seems to be working. Noticed change in boot speed.

Let’s see how that works out.

Hello ExpressCache users,

Just wanted to provide an update on the WIndows 10 ExpressCache fix. The tool in still currently under qualification. We are expecting this tool to still be released by the end of the month. In the mean time if you would like to manually apply the fix I have created the post linked below. This post provide the steps you can take manually to restore the ExpressCache functionality. 



Forum Admin


Slotmonsta - your link dosn’t work …

@georgealon, EC isn’t functioning as intended.

UPDATE: Cache reset on every cold boot (shut down>boot).

Noticed it soon after installed yesterday.

Just woke up (5am est) to test out slotmonsta’s multi install multi reboot method.

Seeing the same results. Cache reset on every cold boot.

A normal restart retains cache and shows some speed changes.

Any help? Any guesses?

Are there users succesfully retaining cache/ec functioning as intended on cold boot on win10?


Damit !!!, sorry to hear that, i really hoped the problem were solved now …

I has not tried it yet, i was going to try Slotmonstas multi install after work today.

Now i have PrimoCache installed, and it works almost fine, but i have the same problem

as you have now, it resets almost every time i boot from cold and the cache has to build op from scratch

i really dont hope it is a Windows 10 problem with cache.

For me a cold boot takes over 2½ min. with the cache working 35 sec. so what a difference.

@mrl wrote:

Slotmonsta - your link dosn’t work …

Link has been updated. The instructions are stickied at the top of this board as well. 



What do you refer as cold boot?

  1. Use Windows menu->power->shut down                   —> the cache should not reset.

  2. Press the power button until the system shuts down  —> the cache will definitly reset.

About the registry key:

Like I told you,  if the registry key is reset by Windows to a wrong value, it will create issues with the app and the drivers.

Here is what I would do at this point:


Plug the drive to a different system and see how the registry looks like.

       - If the registry key is correct, it means that your Windows 10 version or instance is changing the value.

       - If the registry key is also wrong, you should ask SanDisk to exchange that drive.

@georgealon By cold boot I meant pc shut down then booted (as opposed to using restart option from menu).

I don’t have another system. No way to test it out.