Will ReadyCache have a driver for Windows 10?

We are distrusting the support process because there seem to be a significant disparaty between what we are told and how things get solved. On top of that we are repeatedly seeing lousy actions taken by sandisk - its become an expected trend. Everyday you have new people signing up just to push the issue forward hoping to see a solution. That’s why we criticize the process.

You don’t seem to appreciate sandisk support being criticized. Since when criticism is a problem. Why would it be a problem. Its the customer’s voice that get things moving forward. We have seen that before here. This is what happens with lack of quality supervision. You have lost sight of the context, buddy.

Its for your own good. The criticism is for your own good. Its like medication to build better sense so that in the future we customers can sit back chill out and watch these issues get solved in a reasonable manner without us having to get involved.

Until then, we’ll do this everyday.

More people will join in and do this.

I managed to “fix” ReadyCache after Windows 10 update by following steps.

I am not quite sure it works as it should and the driver is loaded as soon as it should for best performance

I did tried and failed to uninstall it couple times before checking the form and old windows files 

  1. Copy content of “c:\Windows.old\Program Files\Condusiv Technologies”  to “c:\Program Files\Condusiv Technologies”  which was emptied during the Windows 10 update

  2. Uninstall ExpressCacheApp

  • This uninstalled the ExpressCache driver also, At least it was removed in my case. I did tried to uninstall both both before copying the stored data so I can’t be 100% sure it works
  1. Reboot

  2. Install ExpressCache 1.3.2 again

  3. couple reboots and it looks like ExpressCache is workig again.

TJuTZu Seems like a great trick. I should have waited a few days before doing a clean install. lol.

Now after a clean install, the software doesn’t recognize the drive. Sitting here dead in the water.

How did you figure it out? Hopefully support gets to take a look at it or make it an official manual fix for the uninstall issue.

Let’s hope someone figures out the drive recognition issue too.

I did the same as TJuTZu and it dont work for me, i cant uninstall the software, “one file is missing”

and the uninstall stops, os its not working for all.

RedCache, I though trying would not hurt too much. If everything goes wrong then I just lobotomize the whole computer and reinstall Windows from scratch (which I should do quite soon anyway).

And according to your and MrL experience this doesn’t seen to be a patent solution for all. I just wasn’t patient enough to wait for official solution.

The instructions got it to uninstall, and reinstall, however on start of express cache, it cannot detect drive. So back to primocache for me

@TJuTZu A fresh install may not work out for you either.

Some users probably (and slotmonsta) claimed to have installed a working EC on a fresh install of windows 10.

But I couldn’t get it work. EC doesn’t recognise the drive.

User @onedollar couldn’t get it to work. Seems like drive recognition is a wider problem.

I’m out of ideas. Let’s see if someone figures it out.

RedCache You are propably right. On my last attempt to uninstall and reinstall EC worked on me, but it could be bacause there were some residues of old installation still on my PC and according to problems others are having by following my steps it was pure luct to get it working at all.

I will update my old post and state out that the procedure will not propably work.

— 

Looks like it is not possible to update old posts on this forum.

I have been keeping up with posts concerning Ready Cache and each day I get more frustrated reading the posts. This absolutely proves how badly hardware and software companies treat customers after you’ve purchased their products.

Sandisk is hardware, Condusive (or whatever company they are now) is software and of course Microsoft is software. So you mean to tell me that all 3 of these large companies and the tech’s they employ did not know, test or fix the problem before it happened? The problem has been “elevated to the highest whatever” and there is still no fix? And with all the advance notification of Win 10, Beta and current product, that no one knew this? HORSE COCKY! Each one is blaming the other and the consumer gets screwed again!

I am am tired of this! Each day I hope to see a fix and we don’t get one. The 2 PR guys in this post defend the practice being used here and the companies are in no real hurry to fix the Win 10 upgrade problem. Their motto, figure it out yourself. So enough of this.

There are 2 ways to “correct” their problem that I know of:

  1. If you have upgraded to Win 10, and you have had it for 30 days or less, you can “downgrade” back to your previous operating system. That’s what I did and RC works exactly the way it did before the upgrade from 8.1 to Win 10. So much for progress.
  2. You have to do a complete install from scratch. Nothing saved, clean HDD and from disk. Almost like an OEM install. You can’t upgrade because files from the software are “deleted” for the uninstall and reinstall.

But I will never buy another product from Sandisk (I’ll stick to a different brand who really does help to solve problems) or Condusive (or whoever they are now) in any of my builds and will encourage my peers to do the same. I may just get another good sized SSD and do away with both of them. I really did like their product.

In the meantime, I really hope they come up with fix for all you folks! Good luck! I’m outa here

@edd33, A clean install creates a different issue. The software doesn’t recognize the RC drive so can’t install. Myself and probably one or more people experienced this. 

You are on point about the way sandisk is managing the whole thing.

Its weird though. They get high score for their other products. They are one of the largest flash makers.

But the readycache product, at least as appears to be, is run by a bunch of interns (or worse - old timey hires who are not really qualified to hold on to their jobs anymore - because can’t deliver).

These are just expressions of frustrated customers. But the disappointment in this company is very real.

I am most likely to join you on your way out of the sandisk ecosphere. I have a Samsung 850 pro on my desk right now. Have had it for a few months. Didn’t want to use it. Its too fancy for my cheap build. But sandisk fails to deliver again. I have gotten sick of it. (I still don’t understand… in this day and age… they can’t manage to deliver timely updates/fixes. Its as if they are flinging pigeons at each other to communicate with condusiv. Aren’y either of these companies able to hire capable tech guys who can get sh*t done?)

Like yourself and others, I will be highly hesitant to reach for a sandisk product in the future. What a shame.

I haven’t posted on here for while and still see the frustration that this issue has caused.

I really do believe that SanDisk are working and testing a solution with Condusiv ( they have written some of the best disc caching and optimising software in the market). I am sure that they don’t want to upset us even more by releasing something that doesn’t work.

I am currently giving SanDisk until the end of this month to provide us with a Windows 10 ReadyCache solution.

know companies like Amazon are advertising the SanDisk ReadyCache product without saying it won’t work on Windows 10 after upgrade, so the EU advertising regulators with be very interested in this situation. Similarly Maplin, Scan, NewEgg, Walmart, BestBuy etc. don’t highlight that it will not work after you upgrade to Windows 10 - they actually say "minimum system Windows 7!!

Given that the advertisements for this product don’t explain the issues with it under Windows 10, I am sure that the advertising regulators in various countries would be very interested in the issues that we have seen with the ReadyCache product.

Regards

Infinidim

Hi,
ExpressCache AKA Readycahce is greate product. Almost I did not need SSD/SSHD before Win10.

My PC is Lenovo ThinkPAD e430. It has optional small size of SanDisk mSATA SSD in it.

I modified the PC a bit that I replaced origiunal DVD drive to HDD as D:.
Of casue I replaced origonal C: to high performance SSD too.
I used ExpressCache for the D: drive. It was super awesome!!
But, now, I only have the alternatives that are SSD/SSHD and sad.

I have a request for future ExpressCache release.
Until ver 1.0.0, it has exclude drive option. It excludes a drive from the cacheing.  For multiple drive users like me, it is useful option.
Could you come it back life again in the future release? Or implement selective drive option?

Thanks in advance!!
Victory

RedCache wrote:

@edd33, A clean install creates a different issue. The software doesn’t recognize the RC drive so can’t install. Myself and probably one or more people experienced this. 

 

RedCache,

 

The ExpressCache software looks for the ReadyCache drive in the registry. Can you check your registry and see if you see this entry?

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\disk\Enum

 

ExpressCache is looking for one of the two following sub strings:

 

SANDISK_SDSSDRC

VEN_SANDISK&PROD_SDSSDRC

 

Here is the registry on Windows 10 (item 5):

RC Reg.jpg

Just wanted to updated users that are waiting on the Windows 10 update tool. The Windows 10 update fix is currently in qualification. We still expect to release by the end of the month. 

Forum Admin

slotmonsta

Checked registry.

“services” under “current control set” isn’t there.

Searched for SANDISK_SDSSDRC - not found.

Searched for  VEN_SANDISK&PROD_SDSSDRC -  found under device instance: value data: SCSI\Disk&Ven_SanDisk&Prod_SDSSDRC032G\4&239d8b02&0&020000

found in HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\DeviceClasses{53f56307-b6bf-11d0-94f2-00a0c91efb8b}

Correction: The initial sequence found under currentcontrolset001. screen shot included.

Can you try copying that key to the following directy and let us know if you can then install ExpressCache?

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\disk\Enum

hi RedCache,

Under current control set you should have a services folder. This is pretty standard however this is likely why the ExpressCache software is not seeing the ReadyCache SSD. 

Can you confirm that this is a full Windows 10 clean install? Would you be willing to export _HKEY_LOCAL_MACHINE\SYSTEM_? I can share it with our development team and see if we can find what the issue is with your system. 

Forums Admin

slotmonsta

@slotmonsta

–This is a clean install. Harddrive formatted, partitions changed during the process. All files deleted.

–Rechecked registry. Now currentcontrolset has the keys that weren’t there yesterday. So, under disk>enum its identical to controlset001.

–Tried to install EC again. Got the same error - drive not found.

–Sandisk is sloppy and unprofessional. I’m not comfortable sharing reg data. 

RedCache,

  1. Yesterday you posted wrong information about your registry.

  2. Also, looking more closely at the registry key value that you sent, it shows:

 

“SCSI\Disk&Ven_SanDis_&…” instead of “SCSI\Disk&Ven_SanDisk…”

–> your drive is not found because you have the wrong registry value or the wrong device.

  1. Giving more registry information will not help resolve your issue.

    Windows does not register your device with the right registry information.

Are you using a genuine SanDisk drive?

@georgealon

:S Its the same drive. As real as it was before.

Good find. Checked again. The K in sandisk is missing in both currentcontrolset and controlset001.

Should I test adding the K back in?