Will ReadyCache have a driver for Windows 10?

Here is the screen shot.

What configuration should the RC ssd be in? GPT? Dynamic? Unallocated? Formatted? NTFS?

Any clue why keep getting this error?

Expresscache does not support dynamic disks. To install just have the RC SSD unallocated and the Expresscache software should find and format it. 

Did you reboot the machine like slotmonsta suggested?

Rebooted and ssd shows as unallocated. Still getting the same error.

(Also ssd is probably not broken as it can be formatted and drive shows up as normal. Checked for errors. Accessible and functioning. Then deleted volume to get unallocated status.)

Agreed if the SSD can be formatted and is seen by normal windows tools then the SSD is not likely the problem. Is this a full fresh install of Windows 10?

Its a full fresh install (all files deleted, installed from a disk).

Nobody has any clue what is blocking the process?

Unfortunately I dont. I have sent a link to your post over to sandisk support. 

Thanks for sending it.

Please let us know what comes of it.

Losing hope very quickly here.

This is really, really bad. Any update in terms of when there will be an official fix?

I did the Microsoft online upgrade from Windows 8.1 to 10.

Everything seems to be running OK, I’ve received no error messages, but ExpressCache no longer appears in Task Manager.

However, when I shut down, it takes a LONG time (>5minutes) for disk activity to stop and the computer to power down.

I’d just like to be able to uninstal Express Cache safely.

There isn’t seem to be any response coming from support.

They are busy convincing upper management that there isn’t any issue anywhere.

Why only the readycache product had to be managed poorly.

Generally sandisk gets good support ratings on everything else.

Why, man!! Why?

HI

My cache is down too after Win10, so i also installed PrimoCache and it almost works fine, my pc now can boot in 35 sec. insted og 2½min. but only if its a reboot ! - when i start on cold it still takes 2½ min. to boot so i seems like its not using my cache when it starts cold, do you have the same problem ?

the issue was described pretty well by slotmonsta. It does not sound to me like support is running or hiding or telling management there is no problem. slotmonsta stated the issue was escalated to the highest level and the issue occurs during Win 10 upgrade only due to components being removed by Windows. slotmonsta also clearly stated they expect a fix to be released by the end of the month so not sure why you think sandisk support is trying to hide the issue. that simply does not make any sense.  

We are distrusting the support process because there seem to be a significant disparaty between what we are told and how things get solved. On top of that we are repeatedly seeing lousy actions taken by sandisk - its become an expected trend. Everyday you have new people signing up just to push the issue forward hoping to see a solution. That’s why we criticize the process.

You don’t seem to appreciate sandisk support being criticized. Since when criticism is a problem. Why would it be a problem. Its the customer’s voice that get things moving forward. We have seen that before here. This is what happens with lack of quality supervision. You have lost sight of the context, buddy.

Its for your own good. The criticism is for your own good. Its like medication to build better sense so that in the future we customers can sit back chill out and watch these issues get solved in a reasonable manner without us having to get involved.

Until then, we’ll do this everyday.

More people will join in and do this.

I managed to “fix” ReadyCache after Windows 10 update by following steps.

I am not quite sure it works as it should and the driver is loaded as soon as it should for best performance

I did tried and failed to uninstall it couple times before checking the form and old windows files 

  1. Copy content of “c:\Windows.old\Program Files\Condusiv Technologies”  to “c:\Program Files\Condusiv Technologies”  which was emptied during the Windows 10 update

  2. Uninstall ExpressCacheApp

  • This uninstalled the ExpressCache driver also, At least it was removed in my case. I did tried to uninstall both both before copying the stored data so I can’t be 100% sure it works
  1. Reboot

  2. Install ExpressCache 1.3.2 again

  3. couple reboots and it looks like ExpressCache is workig again.

TJuTZu Seems like a great trick. I should have waited a few days before doing a clean install. lol.

Now after a clean install, the software doesn’t recognize the drive. Sitting here dead in the water.

How did you figure it out? Hopefully support gets to take a look at it or make it an official manual fix for the uninstall issue.

Let’s hope someone figures out the drive recognition issue too.

I did the same as TJuTZu and it dont work for me, i cant uninstall the software, “one file is missing”

and the uninstall stops, os its not working for all.

RedCache, I though trying would not hurt too much. If everything goes wrong then I just lobotomize the whole computer and reinstall Windows from scratch (which I should do quite soon anyway).

And according to your and MrL experience this doesn’t seen to be a patent solution for all. I just wasn’t patient enough to wait for official solution.

The instructions got it to uninstall, and reinstall, however on start of express cache, it cannot detect drive. So back to primocache for me

@TJuTZu A fresh install may not work out for you either.

Some users probably (and slotmonsta) claimed to have installed a working EC on a fresh install of windows 10.

But I couldn’t get it work. EC doesn’t recognise the drive.

User @onedollar couldn’t get it to work. Seems like drive recognition is a wider problem.

I’m out of ideas. Let’s see if someone figures it out.

RedCache You are propably right. On my last attempt to uninstall and reinstall EC worked on me, but it could be bacause there were some residues of old installation still on my PC and according to problems others are having by following my steps it was pure luct to get it working at all.

I will update my old post and state out that the procedure will not propably work.

— 

Looks like it is not possible to update old posts on this forum.