Will ReadyCache have a driver for Windows 10?

I read ‘readyboost’ (standard solution of Windows) should be able to handle more than 4GB on a non-fat drive from Windows 7on … Going to try that…

Fast formatted the drive to NTFS with driveletter, claimed it completely for readyboost from the properties of the driveletter.

It seems to suck up some data, though it’s only passed the 500 megabytes yet after a few reboots, (visible with perfmon) so it’s not very quick.

The purple line of ‘read from cache’ seems to jump up for starting the apps I often start (all the browsers and Word), however when I restart the performance seems to drop again, so I’m not sure whether all speed comes from the Sandisk SSD yet.

At reboot I still have to await some starting processes till it responds to the mouse, hope the crisp response returns…

It seems to clear the cache at reboot… As readyboost should speed up reboot this should be possible to solve…

It’s not Readyboost that is supposed to speed up booting, but Readyboot. (The ‘s’ missing)

For securityreasons Microsoft has crippled Readyboost with a compression/encryption algorithm which forces clearance at reboot, which is not possible to turn off for a normal person, even with some registry experience or access to a policy editor on a professional-machine. Probably only someone who learns how to remotely install windows in an enterprise will obtain the knowledge to turn off the encryption which is rumoured to cause cache-clearance.

I switched back to the PrimoCache-trial. Still 58 days of the trial left to await a solution from Sandisk…

What a mess.

How does a company like Sandisk mess up like this?

It still blows my mind even though us older users have seen it before.

We have seen lack of support or quality checks for the same product.

If they have to re do the software then it could take many months.

It seems like they have only realized they need to update their product just now

after windows 10 is released. That’s terribly dumb in this day and age.

What are the sandisk bosses really doing in the back office?

What are the sandisk developers doing? How the hell do they stay employed.

How do you folks let the customers down like this on the same product - repeatedly?

It’s now Friday the end of the week that they said to me that they have a solution and still nothing has arrived in my email.

I’ll wait till Monday and then start chasing them up.



I hope they are going to release a driver in the next few days or I’m going to sue them. Windows 10 is being tested since January and they still don’t have a driver. My clients are complaining.

 They need to provide updates and support for their products. It’s URGENT.


eBoostr should also work for cache retention after a reboot, but the trial is more restrictive.

Current 1.3.2 seems to run fine on a W10 x64 desktop, but it was a clean OS install (after the upgrade). I haven’t experienced any sudden cache loss after reboot, except for the usual stuff that should cause it by design (large updates, defrag, etc).

Ok, I will try 1.3.2. once more… Use of Revo uninstall after the logging trick I wrote before in this thread lets me reinstall that one from scratch.

At this moment I use the PrimoCache trial, that gives crisp speed and still 56 trial-days left.

Again “ExpressCache can not launch. Try using the original user account for the first time.”.

I’ll try to uninstall the app and the driver separately…

Still the same problem. If I launch eccmd -info it says:

C:\WINDOWS\system32>eccmd -info
ExpressCache Command Version
Copyright® 2010-2014 Condusiv Technologies.
Date Time: 8/10/2015 15:14:14:870 (PC_VAN_GEBRUIKE #0)

Failed to retrieve product license information.


Should I reactivate it somehow?

I runned the installer again, and this time with log. Apart from that I executed both the inf-files in
C:\Program Files\Condusiv Technologies\ExpressCache\excfs and 

C:\Program Files\Condusiv Technologies\ExpressCache\excsd

Now I don’t have the licence message anymore and the commands

eccmd -partition


eccmd -format

are running again.

eccmd -format stalled and wasn’t even neccessary.

I’ve got 1.3.2 running now!

Thanks for posting Rmast, can you post brief steps on what you did to get it back up and running?

Currently using primocach which is working quite nicely (no random cache resets)

I have just had anothe long discussion with SanDisk support for our region (UK etc) and basically go nowhere.

All they said really was " our engineering department is working on it ".

They would not give any timescales or anything - so unless I use a third party caching product I have a useless 32 Gb SSD in my machine taking up a SATA port.

I really have no confidence in SanDisk fixing this issue even though they could have easily have fixed it either while Windows 10 was being shipped as part of the Insider program or even after version 100240 was shipped - which actually ended up as the version they finally released with a couple of patches.

Any updates I will post here.



@rmast wrote:

eccmd -format stalled and wasn’t even neccessary.


I’ve got 1.3.2 running now!

32 or 64 bit and please post how you did it please as there will be a lot of people interested.

Thanks in advance


I don’t have a configuration in which I can reproduce all steps, and don’t know where anyone gets stuck.

My suggestion at this moment (for Windows 10 x64) to get the current install running would be:

Doubleclick on

C:\Program Files\Condusiv Technologies\ExpressCache\excfs\excfs.inf


C:\Program Files\Condusiv Technologies\ExpressCache\excsd\excsd.inf

Disable and uninstall PrimoCache if you installed that.


remove the 29 GB volume in diskmanager

Run eccmd -partition

Start ExpressCache as you allways would. It should run now without annoying popup.

If it doesn’t or you’re anywhere between install and uninstall:

First, get the (un)install working by clearing Expresscache from registry and files.

If during (un)install the setup still complains there is a previous version installed find the

file ‘expresscache.msi’ on your (Windows) c:-drive during setup.

It must reside somewhere around %LOCALAPPDATA%\Temp with the most recent timestamp.

From (a copy of) the directory run 

msiexec /i expresscache.msi /Lv* output.txt

which will give a file output.txt, which contains a pointer to the obstructing remnants.

Uninstall and reinstall expresscache 1.3.2, and follow up the requested reboots.

Now continue at the suggestions at the top, so

Doubleclick on

C:\Program Files\Condusiv Technologies\ExpressCache\excfs\excfs.inf


C:\Program Files\Condusiv Technologies\ExpressCache\excsd\excsd.inf


Run eccmd -partition to partition the 32 GB Sandisk SSD.

If you still experience issues with (un)install use Revo Uninstaller trial to remove all remnants with a managed uninstall, after reinstalling everything you installed to get things running.

Revo Uninstaller will lookup all files and registry-entries in the MSI that can probably be left by the uninstall.

That’s it.

Please post if you succeed with this manual, or else, what eccmd -info shows… (probably still some licencing issue?)


I didn’t have the folder with the inf driver files but I did have a few alternate installs for ExpressCache, I tried one of those and eventually “setup_x64.exe” gave it to me.  I believe that one was posted in this thread.

I ran Revo Uninstaller first to get rid of any old files I had then installed it.  I could not run eccmd -partition, it just gave me some error every time and running eccmd -info told me nothing was being cached.  I right clicked and installed both of those inf files since double clicking opened them in a text editor.  Tried eccmd again and both still said the same.  I uninstalled it through Windows I believe and then grabbed ExpressCache 1.3.2 and ran that installer.  It took a long time to install the drivers during setup, like 5 minutes or something, it always gave me an error at that point before though which it didn’t do this time.  Install finished fine and I restarted then opened ExpressCache which seems to be working.

I currently have 10gb cached and I’ve restarted a few times to make sure my cache wasn’t going to randomly disappear.  So yes I have a working ExpressCache now, thank you.  I think it was a combination of those inf files and Revo Uninstaller.


Some of the users have figured out ways to get it to work. I hope Sandisk folks are looking into the methods and hopefully release an installer that gets it done.

Right now, can’t uninstall it and can’t install version 1.3.2 back into the system.

Fast, man. We are waiting.

1 Like