Will ReadyCache have a driver for Windows 10?

I’ve gotten this to work, there are basically 3 issues, see here and its link: http://forums.sandisk.com/t5/SanDisk-ReadyCache-SSD/Solve-my-Win10-ReadyCache-issue-early-Win10-upgrade-user/td-p/347672

  1. The Win8.1 to Win10 upgrade for early adapter can possibly cause the folder to be removed, solution is to copy the files from the Windows.old path and attempt a manual fix above.  There is possbly some interference from the account permission, so you need to STOP the ExpressCache service so that it would uninstall fully.  This doesn’t appear to happen with a Win 10 upgrade THEN putting in the ReadyCache after.  If you don’t have the Windows.old file, Sandisk support can provide that, they should just put up a download link for it, I’m not gonna do it because I dont’ work for Sandsik.

  2. You need to remove as many files as you can from your %tmp% path before you start, for some reason the extractor doesn’t overwrite the files OR is picking up some old files from the %tmp% path, and the installation will go wrong. (in my case, eccmd returns license issue AND ExpressApp launch issue).  While you are at it, delete the Condusiv folder under Program Files as well just to be clean.

  3. You want to delete of the partition on the ReadyCache drive, after the installation you will see a new partition being created, that’s usually a good step to verify if the installation is even working.

Hope these tips would help.  It took me a long while crawling numerous forums and finally solved this.


I have faced the same (Windows 7 upgraded to Windows 10 adopter) issue and I have been patiently waiting for the fix just like the others on this forum. I must have tried the manual fix a few times but it doesn’t work. It gives me the dreaded message about the missing msihelper.dll file. I cannot uninstall the program from the control panel due to the same missing dll error.

If there is a custom installer file to fix this error I would love to have it.


I haven’t attempt this, ideally once you copy the Windows.old file back to the right location, it should just uninstall.

If not, you can try some uninstaller tools like Revo uninstall or so.

Bought ReadyCache when it first came out.  Day 2!  Worked great.  MB smoked but disks survived.  Went to load ReadyCache again, but I needed the Key!   Couldn’t find the key for almost 2 years.  Finally found it in a book the day after I loaded Windows 10.  Have tried everything with no success.  

I read that it only took Microsoft 10 months to develop a working model of Windows 10.  If SanDisk has been working on a driver since January, SURELY they must be close!   …or maybe they have abandoned the work?

Sure like to know one way or the other.  Is it coming?

I think the first step is to copy the Windows.old files back so that you can uninstall it.  The manual workaround works, the problem is that you have to remove the %tmp% junk so that you get a good installation.

It seems this has been an issue for some time. I saw a January timestamp for this issue. I’d love to be able to use my hardware again. It worked very well prior to my upgrade. I am almost sorry I did it so fast.

Just adding squeaks to the wheel.

C. Closs

1 Like

I offically got a reply from Condusiv after waiting weeks and they said, “We have already released a new driver to Sandisk and it is their responsibility to release it.” So I guess we’re waiting on the release or Sandisk likes losing customers since their drive was doing so well. Anyway, I installed my ReadyCache in my Toshiba Satellite Laptop in place of my Optical DVD drive. I ran the installer as an Admin with Windows 7 Compatibility and it is up and caching just fine. Let’s hope that Sandisk releases the Driver they already have soon!

With SanDisk unwilling or unable to come up with a driver for ReadyCache maybe Western Digital can get it done.   

I’m forced to use eBoostr. This **bleep** thing at least works properly under Win10 and it was never even designed for it. But ExpressCache, nope, can’t even install that crap. This is so lazy Sandisk. And don’t hope for WD to change much. Sandisk is just their division and it’ll take ages for WD to afect it in any way. Especially for something as insignificent as those few thousand ReadyCache users…

Lenovo have released a WIndows 10 driver for their version of the product so why cant Sandisk.

This issue has nothing to do with a Driver for Windows 10. I am not sure where that misconception came from.

The issue is that during the upgrade to Windows 10 the Microsoft upgrade tool removed critical components of expresscache which caused the software to not be fully installed. These components are still present in the Window.old folder. To uninstall the software there are manual uninstall instructions posted in this board. Once you have expresscache uninstalled you can simply reinstall it. No update is needed. 

If you do not have the windows.old folder on your computer contact sandisk support and they can send you a Beta tool you can use to uninstall expresscache. once that is done just reinstall expresscache.

Microsoft has now patched the Windows 10 upgrade tool so anyone who upgrades to windows 10 now will not see the issue. 


Got this when trying to install the latest driver:

Missing file:///C:/ProgramFiles/CondusivTechnologies/ExpressCache/msihelper.dll 

correct, you will need to manually uninstall expresscache before you can reinstall it. 

instructions for manually uninstalling expresscache


If you have deleted the Windows.old folder contact sandisk support and they can provide a beta uninstall tool that will remove expresscache. Once that is done you can reinstall expresscache normally. 

I’m sorry but my Windows.old is empty so I can’t  run the uninstall process, can u send me the original files so I can continue the manual fix?


ExpressCache can’t even be installed from scratch. It craps out during drive detection…

Please send me the installer. Thanks


Contact support and tell them you need the Beta tool called  Windows 10 cleanup. They will email you the link.

I had the same exact issue and had already deleted  my Windows.old folder. This tool worked for me.

When you run it, the command window flashed the screen for a second, then it is done. You should be able to run the ExpressCache installer with success. 

Kind Regards,


 Install appears to have succeeded after using the beta removal package for Windows 10. One problem solved. Now, ExpressCache does this every single time on boot up. Grrrr. I have removed it, rebooted, re-installed it and every single time it says it successfully installed but no joy.

  2015-12-11 15_12_39-Reply to Message - SanDisk Forums.png

I am running Windows 10 x64, I never had ExpressCache runned before.
I now try to install ExpressCacheSetup.exe, but the software says there is no Sandisk SSD, but it is connected. I tried switching the HD and the SSD to the other SATA connector. But also that is not helping, but I know that the both SATA connectors in my laptop are working now.
SanDisk tells there will be software to recognise the SSD, can I get it? I can’t install your product in computers of my customors now…

so is there any option to get this to Windows  10…