Will ReadyCache have a driver for Windows 10?

Yeah. If people’s boot speeds are anything like mine, it can’t be satisfying.

Part of the boot sequence is being sped up by cache and part of it isn’t.

It seems obvious.

Hi, is there an update now that we are into September…it was said that it’d release by end of August.

Still nothing. No updates. Mid September. The software obviously needs to be updated. Its not fully functional in windows 10.

Hi RedCache

I gave it up and installed a real SSD you might do the same since the prices are lower than ever.

It really RULES like a new 4 times faster PC with a boot time 8-10 sec. im an wery happy now …

Regards MrL

Assuming you have a W10 system with ReadyCache working and fast boot enabled, there’s a way to further decrease Windows load time if your system is suitable. Windows 10 can compress system files, and should automatically do it if it detects a small SSD as OS drive.

This uses a very light compression algorithm, and can also be used on a HDD, so that it needs to spend less time reading, with also the slight advantage of less cached lbas on the cache drive. The downside is a little extra CPU occupancy when accessing system files, but overall the decompression time of all of those acessed files to RAM can take less time than the slow hdd loading extra KBs. 

To verify current state, on admin prompt you do:

compact /CompactOS:query

To enable OS files compression you do:

compact /CompactOS:always

To disable OS files compression you do:

compact /CompactOS:never

Both enabling and disabling takes some time, and probably it’s a very bad ideia to interrupt both processes. End the end, you’ll be notified of the achieved compression ratio (usually close to 1.6:1).

To see results, you must give it time for ReadyCache to cache sensitive boot files again (three restarts after waiting some minutes after each to fill cache should do). After that, when the Windows own fast boot works in conjunction this compression, it can give you even faster boot times.

Not every computer is the same and, in some PC’s where there’s less CPU to spare, it can have a negative effect. But then, it’s easy to revert.

@MrL Did you end up getting a Sandisk drive? I highly doubt that after the experience with readycache, any of us would get sandisk drives.

@RedCache - After this MAJOR failour from SANDISK i must say i lost my trust in the product, so i didn’t look for it in the first place

i ended up with a KINGSTON V300 with 240gb and a 120 gb + i formattet my expresscache to a drive of 16gb SSD.

Used Acronis True Image 2014 to clone my HD to the SSD, then upgraded to Win10 = boot time of 8-10 sec.

under 20 sec. i have startet Chrome and loaded som news from the web = IAM A WERY HAPPY MAN !

almost at the end of September, still waiting…and waiting…and waiting…

@taisui wrote:

almost at the end of September, still waiting…and waiting…and waiting…

Can I suggest that you open a case now with SanDisk.

When I did they came back to me and fixed the issue.



So, now is october and there is no oficial fix/update, should we start looking other brand of SDD to solve our needs?

There was a manual fix that was posted few weeks ago. If that doesn’t work, please let us know and we’ll send you an installer that should fix it.

Since, this problem occured on early Windows 10 adopters, we are only releasing a manual fix at this time. This issue should not occure if you upgraded to Windows 10 recently.

please send the installer

 Send me an email address through private messages to receive the installer.

Please send me the installer too.

I need the installer, too. Could you send me the installer to my e-mail adress or give me / us the link?

Thank you frim Germany


I’ve gotten this to work, there are basically 3 issues, see here and its link: http://forums.sandisk.com/t5/SanDisk-ReadyCache-SSD/Solve-my-Win10-ReadyCache-issue-early-Win10-upgrade-user/td-p/347672

  1. The Win8.1 to Win10 upgrade for early adapter can possibly cause the folder to be removed, solution is to copy the files from the Windows.old path and attempt a manual fix above.  There is possbly some interference from the account permission, so you need to STOP the ExpressCache service so that it would uninstall fully.  This doesn’t appear to happen with a Win 10 upgrade THEN putting in the ReadyCache after.  If you don’t have the Windows.old file, Sandisk support can provide that, they should just put up a download link for it, I’m not gonna do it because I dont’ work for Sandsik.

  2. You need to remove as many files as you can from your %tmp% path before you start, for some reason the extractor doesn’t overwrite the files OR is picking up some old files from the %tmp% path, and the installation will go wrong. (in my case, eccmd returns license issue AND ExpressApp launch issue).  While you are at it, delete the Condusiv folder under Program Files as well just to be clean.

  3. You want to delete of the partition on the ReadyCache drive, after the installation you will see a new partition being created, that’s usually a good step to verify if the installation is even working.

Hope these tips would help.  It took me a long while crawling numerous forums and finally solved this.


I have faced the same (Windows 7 upgraded to Windows 10 adopter) issue and I have been patiently waiting for the fix just like the others on this forum. I must have tried the manual fix a few times but it doesn’t work. It gives me the dreaded message about the missing msihelper.dll file. I cannot uninstall the program from the control panel due to the same missing dll error.

If there is a custom installer file to fix this error I would love to have it.


I haven’t attempt this, ideally once you copy the Windows.old file back to the right location, it should just uninstall.

If not, you can try some uninstaller tools like Revo uninstall or so.

Bought ReadyCache when it first came out.  Day 2!  Worked great.  MB smoked but disks survived.  Went to load ReadyCache again, but I needed the Key!   Couldn’t find the key for almost 2 years.  Finally found it in a book the day after I loaded Windows 10.  Have tried everything with no success.  

I read that it only took Microsoft 10 months to develop a working model of Windows 10.  If SanDisk has been working on a driver since January, SURELY they must be close!   …or maybe they have abandoned the work?

Sure like to know one way or the other.  Is it coming?

I think the first step is to copy the Windows.old files back so that you can uninstall it.  The manual workaround works, the problem is that you have to remove the %tmp% junk so that you get a good installation.