Will ReadyCache have a driver for Windows 10?

lol its not going to work is it. heh.

I’m about to try it out right now.


EC now installed after putting the K back in.

Cache is filling up. I’ll give it a day or two until I can figure out

if its actually working.

Any ideas why windows registry screwed up?

Any guesses if the fix will be reversed by windows?

(That’s all it took to troubleshoot for now? No offense. But it could have been done earlier/quicker. This is the reason why sandisk and support gets labeled sloppy. No offense to you. Thanks for helping out. Thanks to others too. But sloppy, dude.)

Make sure the key looks like this:

SCSI\ Disk&Ven_SanDisk&Prod _SDSSDRC032G\xxxxxxxxxxxxxxxxxxxx

And yes it should work if the key is not changed.

After installing and rebooting, take a look at the key again.

The K is gone.

The fix was reversed.

But did a cold boot.

EC seems to be working. Noticed change in boot speed.

Let’s see how that works out.

Hello ExpressCache users,

Just wanted to provide an update on the WIndows 10 ExpressCache fix. The tool in still currently under qualification. We are expecting this tool to still be released by the end of the month. In the mean time if you would like to manually apply the fix I have created the post linked below. This post provide the steps you can take manually to restore the ExpressCache functionality. 



Forum Admin


Slotmonsta - your link dosn’t work …

@georgealon, EC isn’t functioning as intended.

UPDATE: Cache reset on every cold boot (shut down>boot).

Noticed it soon after installed yesterday.

Just woke up (5am est) to test out slotmonsta’s multi install multi reboot method.

Seeing the same results. Cache reset on every cold boot.

A normal restart retains cache and shows some speed changes.

Any help? Any guesses?

Are there users succesfully retaining cache/ec functioning as intended on cold boot on win10?


Damit !!!, sorry to hear that, i really hoped the problem were solved now …

I has not tried it yet, i was going to try Slotmonstas multi install after work today.

Now i have PrimoCache installed, and it works almost fine, but i have the same problem

as you have now, it resets almost every time i boot from cold and the cache has to build op from scratch

i really dont hope it is a Windows 10 problem with cache.

For me a cold boot takes over 2½ min. with the cache working 35 sec. so what a difference.

@mrl wrote:

Slotmonsta - your link dosn’t work …

Link has been updated. The instructions are stickied at the top of this board as well. 



What do you refer as cold boot?

  1. Use Windows menu->power->shut down                   —> the cache should not reset.

  2. Press the power button until the system shuts down  —> the cache will definitly reset.

About the registry key:

Like I told you,  if the registry key is reset by Windows to a wrong value, it will create issues with the app and the drivers.

Here is what I would do at this point:


Plug the drive to a different system and see how the registry looks like.

       - If the registry key is correct, it means that your Windows 10 version or instance is changing the value.

       - If the registry key is also wrong, you should ask SanDisk to exchange that drive.

@georgealon By cold boot I meant pc shut down then booted (as opposed to using restart option from menu).

I don’t have another system. No way to test it out.

In that case the cache will reset because it is not a normal or gracefull shut down. The cache will be corrupted if the system shuts down without notice.

Why is it not a graceful shutdown?

May be I wasn’t clear enough.

Cold boot meant - using shut down from start menu. Then booting.

Hopefully this gets resolved soon, 4 more days and a whole lot of people are going to be upgrading all at once…

@georgealon Subverted cache reset by disabling fast startup in power options in windows.

Cache is retained in cold boot. But system is much slower.

Boot speed isn’t all that improved. I can see some improvement. But its slower than it was on win7.

Can it be checked if EC is actually working as intended on win10?

With fast startup enabled bootup was faster. But EC needs to be modified to retain cache.

I hope they are aware (and motivated to deliver a fix) of it.

I am sure that SanDisk are working hard on getting the Windows 10 issues resolved. Once they get a fix from Condusiv they will have to do a lot of internal testing to ensure that the solution doesn’t break anything else.


Infinidim  :smiley:

Some positive feedback :laughing: the manual method posted in the sticky thread at the top of this forum did work for me, although I ended up being prompted to uninstal twice in a row after changing the service to manual.   Once installed the cache did take several reboots before statring to fill at a ‘normal’ rate but seems to be working fine now.

@wetnap wrote:

Hopefully this gets resolved soon, 4 more days and a whole lot of people are going to be upgrading all at once…

The Windows 10 update has been packed so anyone upgrading for the first time will not run into this issue. 

If you have upgraded prior to the Windows 10 patch try the manual uninstall instructions below.


Link is broken

Good news!

I’m pleased to say I bit the bullet and upgraded to Windows 10 today and I have 7GB of cache and my PC seems just as responsive as it did under Windows 7.

Of course, this doesn’t help anyone who is stuck in Windows 10 with a non-working ReadyCache.

I had previously tried to get RC working in Windows 10 by installing/reinstalling & registry cleanup etc but in the end reverted back to Windows 7 using Windows 10’s “Go back to Windows 7” option until a fix was reported to be ready.  This might be a route for some of you to consider.

Sandisk - shame you didn’t test with the Windows 10 before the release date so we didn’t have to go through this - but well done on getting a working fix out now.