Why is my micro SD card so irreparably corrupted?

My 32gb Sandisk micro SD which I had in my Sony Xperia ZR, suddenly got completely and utterly corrupted. I have scoured the internet quite deeply for solutions but none seem to work.

Things I have tried:

  1. I have tried formatting it with my computer. It shows up in my explorer window, but it cannot read the total space and occupied etc and when I right-click on it, the explorer window becomes non-responsive for a minute. After that the context menu appears and when I select it to format with the appropriate parameters, it returns an error that the format failed.

  2. I have tried formatting it with the Command Prompt using the format command. When I set the filesystem as FAT32, it says the cluster is too big. With exFAT, it returns that an error occurred while examining the boot region.

  3. I have tried using Disk Management. It shows the space as Unallocated Space. When I get around to making a new partition and select the appropriate parameters, it returns “Data Error (Cyclic Redundancy Check)”.

  4. I have tried using Diskpart utility in cmd as well. There are no partitions on the Disk 1 (my memory card). When I try to make one, it returns a Data Cyclic Redundancy Check Error.

  5. I have also used chkdsk with the appropriate parameters. It simply says that it does work on RAW file systems.

  6. I have also tried formatting it on an Android device. When I plug it in, I get an error that the card is damaged and asks me to format it. When I click on format, it does so and then it says that it is preparing the SD card, after which, the error of the damaged card appears again. And the cycle goes on. I have tried putting it in 5-6 different android devices from different manufacturers, but the same result. I have no cameras that allow me to format the card. They simply show that the card in unreadable.

  7. Third party programs I’ve tried:
    * ZAR (Zero Assumptions Recovery): It stops responding when enumerating devices with the micro SD card plugged in.

* MiniTool partition Wizard: All the options are greyed out when I click on my card.

* EaseUS Partition Wizard: It also returns with an error, no matter what I try.

* HP USB Formatting Tool

* SD Formatter

* HDDLFF; etc.

How it began:

I was transferring some photos from my friend’s PC. To boost the transfer speeds, I decided to connect with MSC (Mass Storage Mode) instead of the default MTP (Media Transfer Protocol). It only connects the memory card, which was fine by me. He copied the photos, I safely ejected it out, and unplugged it. There was a notification which said that the SD card was damaged and needed to be formatted. Even after I did format it, the error appeared over and over again.

Another quirk: When I plug it into my laptop’s in-built SD Card reader, with a micro-SD card modulator, it shows no response. I had given up all hope, but just decided to connect it with another, older, card-reader. It somehow seemed to show up on my PC, but that was it. Like I said, no method seems to fix it.

I strongly insist, that you read all the things I have tried before suggesting a solution. It’s long, but please really help me out here. I don’t even care about the data anymore. I’m scared ****less. Nothing seems to fix this and I’m pretty sure there’s no hardware damage, as nothing happened, and the card looks absolutely alright from outside. Just help me get this to work. I’ll be really thankful!! *fingers crossed*