white screen problem

i have same problem of white screen i tried every thing but nothing works for me then i emailed my problem to sansa 2 times and i got the same email both the time…it was an auto generated response…my RMA id is 235960 and my player is under warranty…now i have left with this option only…to replace it but don’t konw when sansa support will contact me to replace it…meanwhile the sansa updater doesn’t install in my dell xps(i’m using a proxy server) it says"no internet connection fix this problem and try again" what will i do ?..i don’t buy it to face problems…plz help

I just experienced a bizarre white screen issue myself. This may be of no help to you but I’ll post here because the topic fits.

I’ve only had mine for a few days so I know very little of how it works. After some initial frustration when I first got it, I loaded up a bunch of videos, MP3s and photos and it was working perfectly.

This morning, I turned it on and got the white screen problem. Occasionally, I could get the menu but that would lock up (unable to select anything). Then it would just turn white and shut down. Or it would lock on a menu and be entirely unresponsive…couldn’t even turn it off. 

I tried all of the standard fixes (factory reset…hold this, hold that…everything). Nothing worked.

I plugged it into my computer to see if it was recognized. Surprisingly, it seemed entirely normal to my my computer. It was recognized, all the files were there. Everything seemed normal. I unplugged it from the computer and tried it again. Still didn’t work! It would come on. But the menu would be locked. I couldn’t turn it off. The screen would go white and it would turn off.

So I plugged it BACK into my computer. The computer still recognized it perfectly. All the files were intact. I could play the videos from the Fuze using the Windows Media Player. 

Then I tried one last experiment…just for the heck of it. I found an old MP4 file and ran it through the Sansa Media Converter and I put it on the Fuze. I unplugged the Fuze from the computer. I got that little message on the Fuze “Refreshing Your Media”.

After that, the Fuze returned to normal! All Functions are exactly as they should be. Everything works.

Don’t ask my why. I have no idea. But for some unexplainable reason, having the Media Converter access the Fuze and load a file seems to have fixed it. For those of you with a similar Fuze problem, this is one more thing to try before you throw it out the window.