where are my mp3s???

fuze+ issue:

i drag n drog some mp3s (about 1Gb in total, different bitrate too) but the player doesn’t read them. I turn it off and on again but they are not showed in the list of, say, artists or albums…They appear only in my pc when i connect it to the player. I’m getting a bit sick of it, this player is full of problems

Look in your Artists list. Is there an ‘Unknown’ listing? Are your ‘missing’ files there? If so, they either don’t have ID3 tags, or for some reason the tags are un-readable by your player.

no, there isn’t any Unknown listing and most of them have the id3 tags (i didn’t check them all). I’ve also charged the battery and the player didn’t turn on, it was like freezed.

Guys, i just need an mp3 player but this stupid device doesn’t do his job, everytime i try to load some music i get a lot of issues, what’s going on? This is not working!

Just out of curiousity, what connection mode are you using, MTP or MSC?

Just out of curiosity, what connection mode are you using, MTP or MSC?

lol i don’t know… how do i go about checking that? also, the player get freezed when i turn it on.

I had problems with the older fuse once when I had music on my player that was not in the correct files.  If you drag music files to your player, they need to be in the music files.  This may not be your problem, but give this idea some thought.  

If this works and you need to do more than just music come back for more suggestions or download the manual.  Some of the things in the manual is good enough for a start.

If this address your problem, you may also need to consider using Windows Media Player to sync music files over to  your player.  Your player comes preset to work with this that program.  

yes, i drag music files plus album arts (not for every album) and sometimes there are other files in the folders but not in every folder.

I’ve already used WMP and, no thanks, i will not use it anymore for this purpose.

Anyway i plugged the player in the laptop and i deleted every file from the folder Music and Podcast but it is still loading after almost 30 minutes. I’ve already cleared those folders once or twice and that worked, but not now.

Come on guys, this is not rocket science, this a mp3 player which doesn’t load mp3s :cry: and i don’t care about the functions Video,photo,audiobooks…

Is there any way to delete this software and play my musit without using that?

No, there isn’t. But…

This sounds like it could be a classic case of incorrect tags, to me. You see, in the world of storing text, there are multiple so-called “character-sets”, that is forms of digital code that represents  charecter, such as a number or letter. Now, the Fuze+ is very picky about which character set is used. Personally, I don’t know what the difference is between sets, only that the Fuze+ must use ISO-8859-1. Pretty much everyone on this forum who knows this (myself included) uses MP3Tag.

You can download this program, and re-tag all of your mp3’s, and that *should* fix your problems. Just make sure to go into the tools menu and click options. Then, under the “tags” section, click “mpeg”. Under “write” click “ID3v2 ISO-8859-1”. Click okay. Then, click “Change Directory” in the File Menu, navigate to where ever your mp3’s are located, and resave their tags. Now, try reloading them onto your player.

how long will it takes to retag my discography? “and that *should* fix your problems” lol …i have to waste my time and you are not even sure whether that works… Why don’t you optimize the software? is it too expensive to do?

I’ll reset this garbage again and again and i’ll try this mp3tag, be sure i’m going to write a very nice review in the seller’s website.


No one you have talked with thus far on this thread works for Sandisk.  They are just people like you trying to find solutions to problems and help others find solutions to their problems regarding the Fuze+.  Keep your posts nice or people won’t respond at all.

ok, apologies for that.

I’ll look for a technical support then.

@grgr wrote:

ok, apologies for that.

I’ll look for a technical support then.

Frustration can indeed make us crazy at times . . . here’s the link to SanDisk Tech Support contact information. If possible, I’d call rather than e-mailing or doing the live chat thing. You’ll usually get faster service and more “instant gratification” that way.


yes, both frustration and the time wasted for it. Anyway, thank you for your understanding and the link as well :smiley:

Actually i don’t know what to do, i’ll try to make it works as i don’t think i’ll get a refund and even if i get a replacement i won’t be very happy  :slight_smile:

well… i’ll try to reset everything… have a good night!

What connection mode are you using, MTP or MSC? This is what I’m thinkingg while reading the queries…:robotvery-happy: 

I just purchased an 8gb Fuze+ unit just yesterday.  I have 40+ albums transferred over to the unit and yet it can only see 6 albums.  I have been using tag editors for years and never had this problem.  I have used two different tag editors in windows and it will not make any difference.  I have tried editing the tags in both windows and linux, no change.  I have also tried the mp3tag program mentioned above and it made no change.  The only thing left to try is to edit the tags one song at a time by right clicking on the file properties in windows and editing each individual field.  This is out of the question.

And I have tried connecting with both MTP and MSC and editing the tags.  I don’t know what else to say.  Frustration set in yesterday, which seems like a long time ago.

Edit the tags on your computer, then transfer them to the player. ID3v2.3 ISO-8859-1 is the tag format that works best.

Don’t know what other tag editors you’re using, but MP3Tag works great and can change them ‘en masse’ without a lot of time or trouble.