When will the next release of ExpressCache arrive?

Glad to hear that you’re working hard to get this right.  Similar to others in another thread, my computer locks up when the SSD is too full… and sometimes, Windows 7 “helpfully” goes into recovery mode… I’m hopeful that you will have software that works with the SSD!

@giuseppe wrote:

Smart move. Leave no stone unturned. :stuck_out_tongue:

Hi. I totally agree.

I’m actually glad that they are taking the time to make this new build solid.

Good food takes time to prepare. :wink:

Flavio

I wonder if we will get it this week …

Hello Community,

I have been monitoring the Forum and eagerly await the new release of ExpressCache.

It is my hope that it will be well worth the wait.

Patience.

Compumind :smiley:

1 Like

I hope so, because I’ve resorted to disabling it, theres no performance difference, and I’m pretty sure it makes performance worse at this point with all the cache flushing.

I really hope they still release the new version this week or provide an update on it’s release.  I need some good news this week.  My car just broke down.

The upcoming release of ExpressCache has been pushed back until next week. We are still investigating an issue that we hope to include a fix for in the next release. Please see below for a list of issues that are confirmed to be fixed in the next release.

Bugs Fixed:

  • Fixed Titan defrag engine crash.

  • Fixed issue with accessing removable devices.

  • Fixed reference counting issue in the I/O error handler.

  • Added url link to the device unavailable message

  • Chart scaling in performance monitor

Known issues:

  • Freezing during boot (hanging at windows logo for 10 to 20 sec)

We are currently investigating the hang during boot issue and hope to have root cause soon. If possible we would like to include a fix for this issue in the next release along with the other bug fixes. Thank you for your patience and understanding. 

Forum Admin

slotmonsta

Will there be a fix for:

Every time the readycache drive is fill (within a week, most times about 3 days, playing games), the system crashes and the cache resets, after system restart everything is normal, but now the cache has to start all over again.

do you know about the problem and will there be a fix soon? As I have be reading about other users with the same problem.

Jay

No fix for cache reset coming out of sleep?

That sucks.

1 Like

Agree with JayJay - don’t release until you can fix the system crash/reset after cache drive is full!

1 Like

@slotmonsta, gls and others,

What about these items not mentioned?

Hope you are reading all the posts, especially the ones with the GUI getting in the way.

 

The GUI should -

 

1) Have an option to minimize to the system tray upon boot.

2) Have an option to not start with Windows, but be invoked manually from the start menu…

Also - from wetmap…

"Yea and of course fix the thing where it constantly accesses drives to keep them awake for no reason.

 I’m getting tired of manually stopping the service every night."

and RedCache…

“fix for cache reset coming out of sleep?”

Promises were made to make this release right…

You can still do this.

Please do not post the new revision until these items are corrected!

Please respond as to the above items.

Thanks,

Flavio.

@slotmonsta, gls and others,

What about these items not mentioned?

Hope you are reading all the posts, especially the ones with the GUI getting in the way.

 

The GUI should -

 

1) Have an option to minimize to the system tray upon boot.

2) Have an option to not start with Windows, but be invoked manually from the start menu…

Also - from wetmap…

"Yea and of course fix the thing where it constantly accesses drives to keep them awake for no reason.

 I’m getting tired of manually stopping the service every night."

and RedCache…

“fix for cache reset coming out of sleep?”

and matt - “don’t release until you can fix the system crash/reset after cache drive is full!”

Promises were made to make this release right…

You can still do this.

Please do not post the new revision until these items are corrected!

Please respond as to the above items. Other users comments and Kudos appreciated!

Thanks,

Flavio.

2 Likes

Hello,

I have to agree with Flavio on his post. Please take the neccessary time.

It’s been so long already - what’s the difference.

Compumind

Hello,

I tend to agree with Flavio on his post. Please take the necessary time.

It’s been so long already - what’s the difference.

Let it be complete.

Compumind

2 Likes

I’ll wait as long as needed since the issue they are trying to fix now affects me.  As long as they continue to give us regular updates on the status of the update development. :slight_smile:

FYI,

Here is the original promise from gls … to fix in the next revision (the one we are expecting).

Note the word - ALL.

 

Re: ExpressCache version 1.3.1 released

 

12-09-2013 12:16 PM

 

We are lookng into this. We have an open dialog going on with Condusiv. There are many thing on this thread that are being reviewed. We will have a new release that will hopefully address ALL of your issues you have raised. No date yet… stay tuned and thanks for your input!

 

For the original post, click here

 

Flavio.

But you could also note the word “hopefully”.

“that will HOPEFULLY address all of your issues”

http://kb.sandisk.com/app/answers/detail/a_id/11720/session/L2F2LzEvdGltZS8xMzkzNzcxMzQ2L3NpZC9EWHhsNGVPbA%3D%3D

New version 1.3.2/1.3.110 posted on the 20th.  The release notes don’t appear to address the instability at startup when the cache becomes full…  Installing this morning, will report back on any further instability.

Unfortunately, this one stinks too.

The newest version has resulted in 3 blue screens of death in the last week.  Prior to installing  1.3.2/1.3.110, I had disabled caching, and my Windows 7 system was rock solid, if a little slow.  Since installing 1.3.2, the same instability which caused me to disable it previously has reemerged.

I am really disappointed.

SanDisk - what say you?  What’s the plan to fix? 

Yea, at this point I get the feeling its slowing my system down, the cache just constantly resets to the point where it might as well not exist.

I recently upgraded my psu because I bought one on sale so i could hand down my psu to another system, doesn’t fix a thing of course.  Not that ssd’s use much power in the first place, but its not oine more factor removed.

I’m really disappointed.