wheel doesn't work I took it apart!

Ok I was stupid and thought the cable for the thumbwheel didn’t matter, wrong does anybody out there know how to put it back together.  I just cant seem to get the cable back where it belongs other then that the player is fine.  I have tried and tried to put it back together and well I just won’t go anybody have any suggestions.  I took it apart because the screen froze and I could not get it to reset, but well I finally got it to reset but of course it doesn’t matter because now it won’t work because I can’t seat the cable HELPPPPPPPP PLEASEEEEEEEEEEEE!!!

The ribbon cable can be pulled free without unlocking the lock tab, but this isn’t recommended.  As you’ve discovered, it’s impossible to reinsert the ribbon.  Look at the white connector.  On one side you’ll see a bar, a dark grey “flap” that must be carefully lifted to unlock the connector.

Carefully raise this flap, and insert the ribbon until it seats.  Then, lower the flap and click it into position.