Weird charging probem 8GB Clip

I just bought a 8GB clip,and it was fully charged when i got it, i then used it until charge was at 15% and i wanted to charge it,so i just plugged it into one of my pc´s for a few hours, but all it accomplished was to remove all remaining power somehow, so i ended up with a clip with 0% power after 3 hours of charge… Then i read it had to be charged on a pc with wmp 10 or 11, and as i used wmp 9 i thought that was the error… I then installed WMP 11, and tried to charge my clip, and here is the weird problem, clip no matter how long it charges, will only show 57% charged, and power seems to drain from it at a very rapid pace now… I updated firmware but problem is still there… If i manage to get 100% charge, if i turn off clip,and turn it on again, low and behold charge level is at 57%, anyone know what is wrong, and potentially know how to fix this?

The best things to try with charging issues are to use a different USB port, and to try changing the USB mode on the device via Settings > USB Mode > MSC, then plug in again.

MSC mode allows the Clip to communicate more easily with the host PC.  Once the device is charged, you can more easily troubleshoot the communications issue.

The Sansa can drop the charging operation if there is a communication issue.  Look at the battery icon.  If it isn’t “rolling”, the Sansa may not be charging.

Test if the Sansa is communicating properly by having a look at the device from the Device Manager.  There may be a yellow triangle singling out the trouble.  The simplest method is to uninstall the Sansa, unplug it, then plug in again, allowing Windows to select the proper driver.


I have tried all those things… I have upgraded firmware,formatted clip, reset the clip, i have changed usb mode, i have changed usb slot, i have around 16 different usb slots,same error on all of them. Also device manager reports correctly in either usb mode,with no yellow triangle. charge icons move as it should, but no power actually gets onto the batteri it seems, except to 57% level, either the icon reports wrong or the battery doesn´t work is all i can figure