Weird behaviour after firmware update

I’m asking this on behalf of my friend who doesn’t like forums.

She bought a Fuze, on my recommendation, and it was working wonderfully, then she updated the firmware to 1.01.22a via the firmware updater program.

Now, when she clicks up on the clickwheel, it skips forward a music track, instead of pausing. In otherwords, an upclick now behaves the same as a rightclick on the clickwheel.

We have tried a factory reset, we have tried reuploading the fuzea.bin file to the root directory in MSC mode (manually updating the firmware). None of these steps have had an effect. The upclick still behaves identically to the rightclick. Is there anything else we have missed, or could try, before sending it back under warranty?

What happens if you put the old firmware back on?

She ended up phoning Sansa, who after a few diagnostics, declared it defective and gave her a reference number for returning it.

It sounds weird that a key command would be suddenly redirected following a firmware update, especially since both versions have the same map for the keys.

I agree, something is amiss physically in the keypad.

Bob  :cry: