USB problem

Good Morning,

I am having a problem that I hope someone can help me solve.

Last week I purchased a Cruzer Blade USB Flash Drive. When I initially inserted the device my computer (Compaq Presario SR1611NX–Win XP Home Edition), recognized the device and it worked fine. I removed it properly and everything was fine. Then, the next day I inserted the device and not only did it not work none of my USB Ports now work. When I go to My Computer and to USB it says “unknown device”. I have tried uninstalling my controllers and hubs and rebooting. Everything reinstalls but I still see “unknown device” and none of my USB connections work.

Does anyone have any ideas as to what I should now do or try?

Thanks

Are the USB ports you’re using in the front of the case or the rear?  If in the front try a rear port.  Rear ports are attached directly to the mainboard, front ports are cable connected. 

Thank you Ed.

I will try that. Will I have to have a technician check to see if the connection on my front USB ports have become disconnected?

If the back ports work and the front ones don’t you won’t need a technician to check, you will have proven it for him/her.