USB plug powers, but doesn't "connect"

Although I’ve had no previous issues with a Clip+ adn a Clip Zip, my Clip Sport when plug into USB ports os powered, but never gets to a connection. Win 7 is seing the device and device manager reports everything is okay. When I run the Sansa updater, it tells that I need to plug in a device even when the Sprt is plugged in. Also, when I attempt to activate a new device with Audible Manager it asks me to plug in a device.

The troubleshooting guide says this type fo problem could be a USB calbe, PC, or device issue. I tried several different as well as different USB port (both direct and by a hub), but nothing works. If it is my PC, any ideas what I can. I’m inclined to think it is my PC since another recent device (not Sandisk) displayed a similar type of problem (the computer recognized the device and reported it as functioning normal, but the software it was meant to work with could not see it).


If you’ve already tried different cables and different USB ports without sucess, the only thing left to narrow it down is to try a different computer.

My new Clip Sport connects and disconnects, seemingly arbitrarily, from my PC when I try to update the memory card through it.

It’s pretty flaky other times as well.  I hope they take all these bug reports seriously, or it’ll be the last Sansa for me.