USB encrypted & Unusable in less than 24 hours - SecureAccess V2.0 Error

22 hours ago i purchased SanDisk Ultra USB 3.0 32 GB with SecureAccess V 2.0 protection.
i run the installation once i plugged it in give me a notification for an updated version, downloaded and ran, and opened the USB and everything went fine, i started backing up some files on it (Large size Family pictures and Videos). all went well for the first gigabytes; but then it started giving me some errors declaring he can’t copy this file or that file (most of the files are videos around 500 mb’s each). i neglected these errors and kept copying my files.
next day was still doing my backups, left the device copying some files, and returned to find the same error, closed it and checked the SecureAccess and it was un-openable… checked the usb to safely remove it and it was not read as connected at all. so i decided to fully shutdown the pc and restart it afterward… did that and since then the SecureAccess is not working, when i go into the UFD and double click the windows program it gives me this message : 

“SanDisk Secure Access V2.0 is not able to write to the usb flash drive. Please check that the drive is not write protected and in case you are using a Guest account, make sure you have write permission for this drive. Click OK to close SanDisk Secure Access V2.0”

knowing that i am an Administrator on this pc. and that YES the drive is write protected "Duh !! " 

when i try to overwrite/delete the SanDisk Secure Access file on the UFD (As i read online it was solving some issues). it gives you can’t write on this drive as it’s write protected. 

When i try to format the whole drive it gives me the same message.

so for now , after 24 hours from the purchase, the UFD is totally unusable for me, and the Security software seems hugely buggy :\

Stats :
My device that i USED :

HP Laptop 
Windows 8.1
Core i7, 6 GB Ram, 
UFD : SanDisk Ultra 32 GB
Ports used : USB 3.0 & USB 2.0 

ANY YES i tried another PC :slight_smile:

:smiley:   Hi OrionDelgado,

Dear member of SanDisk Community, welcome.

Please, do not grieve more friend, return it, because is dead.

Write protection errors occur when a UFD detects a potential fault within itself.

The drive will go into write-protected mode (or read only) to prevent data loss.

There is no method to fix this.

_Contact SanDisk Technical Support _ who will replace the device _ if it’s authentic _ and is within warranty.



Regards, Alfred.                                                           (Google translated)


For sure the secure access is not the best encrypt software you can find online but you have to think that its a free gift software that sandisk provides with the cruzer drives. The software is produced by encryptstick not sandisk itself.

In that case where the stick is write protected you can contact sandisk support to replace the drive with a new one or you can go to the place of purchase for an immidiate replacement.