"USB Device not recognized

My Sansa Fuze was working fine and I love it! But suddenly yesterday, when I plugged it in to the USB port on my Win 8.1 computer to recharge, it said “USB device not recognized” and didn’t do the usual revolving logo screen that says “connected”. But it seemed to charge anyway. Now this morning, it gives me the “not recognized error” and shows that four color logo, but no “connected” and I can’t turn it off! Is it completely dead (very suddenly) or can it be revived at least until I can copy the stuff off and get a new one? Help!

It’s probably the cord going bad.  You can find a replacement generic one at Amazon or cellphone accessory places for about $5.

You want a Sansa Fuze sync cord. The same cord is used for the Sansa E200 so you can also look under that.

Don’t use an iPod cord–it will fry the battery.

The reason I think it’s the cord is that the cord has separate connections for charging and data. It sounds like your data connection went first but you could still charge.

Thanks, Black Rectangle, but that doesn’t explain why when I disconnected it today (after again it said USB device not recognized), it wouldn’t turn off. I kept trying for about a half hour but it still showed the logo; finally it blanked out but I think that’s because the battery was totally dead by then. Additionally, if the cord was bad, why would Windows even see it to try to recognize it? But mostly, I’m doubting it’s the cord because of the problem today with it not turning off. (But it sure would be great if that was all it was!)

I did actually look online to buy a new one, but I see that the the newer versions are getting poor reviews (i.e. the Clip Sport seems hated compare to the old Clip). And the Fuze+ seems quite expensive compared to what I paid for the Fuze (the clip is cheaper but as I said, not so highly regarded in the new incarnations). I really love my Fuze and used to recommend it to everyone!

I think it’s worth it to try the cord. I have had it freeze on after disconnecting–sometimes if I pulled the cord from the computer while leaving it plugged into the Fuze. I would think a faltering USB connection could make it freeze.

You should have been able to shut it off by holding up the power button for 20-30 seconds–not just the usual on-off but a seriously longer time.

I just checked Amazon, and cords are under $4 shipped. Worth a try.


A used Fuze hovers around $60-$70 on Ebay, but you never know whether those are going to die.  

Thank you, Black Rectangle. You’re right that it’s worth a try! I wouldn’t consider a used one since, as you say, you never know. In case it’s not the cord, I will also research the Clip, which is cheaper—although the Sport didn’t get great reviews, Amazon has the older clip (discontinued by manufacturer but doesn’t say refurbished) for about $40. I got a lot of good use out of my Fuze!

I’d give good odds that it’s the cord.  Your problem is all about the USB connection, and the cord is the weak point–unless you somehow damaged the connector in the Fuze, but your explanation doesn’ t suggest that.


There are too many Clips.

The original Clip has no memory slot–don’t get that.

The Clip+ does have a memory slot and is pretty affordable. It has the same sound processor as the Fuze, but with less power to the headphone jack. I can hear a difference, and I prefer the Fuze, but more technical people claim that’s a placebo effect.

$37.49 at the moment at B&H


The Clip Zip can handle m4a files from the iTunes store (though you can’t run it through iTunes, which is fine with me).

The Clip Sport doesn’t have MTP, so everyone who’s used to synching with Windows Media Player (and Overdrive library audiobooks)  is shall we say unhappy.

1 Like

Another quick and helpful answer from you, Black Rectangle; thanks again! I’ve actually been looking at the Clip+ but I thought that was the one that said “discontinued by the manufacturer” and that made me a bit concerned. The really important thing for me is the ability to do playlists; I was shocked in researching today that there are bargain mp3 players out there that won’t do playlists! I don’t use my mp3 player for all that much: my morning run, and four different playlists to put me to sleep at night, as well as some meditation music are the most frequently used things I do with my Fuze. And the odd photo I want to show around and voice recording for memos to self on the commute home. I’m guessing the Clip+ will do all that, and I fear that some of the non-SanDisk bargain brands (only about $10-15 cheaper) won’t. Just really loved my Fuze! I love your suggestion about the cord and will get a new one right away.

Interestingly, I found that although the PC says “USB device not recognized”, the player still charged. Yet a KB article about the Fuze (on Rakuten) I just read online said that while a bad cord can be the cause of the device not being seen by Windows, once you get the popup “USB device not recognized” it usually means a fatal hardware failure.

Fingers crossed, and thanks so much again!

I didn’t know about that “USB device not recognized” knowledge base article, so I hope I haven’t steered you wrong about the cord. I still think it’s worth a try. And if not…sell the Fuze on eBay for parts, especially if you have kept it in good cosmetic shape and the headphone jack still works. It would pay for part of a replacement player.  

As for the Clip+,  I wouldn’t worry about “discontinued by manufacturer.” Just because they don’t make them any more doesn’t mean a new one won’t be good. I just looked at Amazon, and they are art the moment matching the B&H price of $37.49. 

The original Fuze, so sadly “discontinued by manufacturer,” now goes for huge increases over its original price because it was better than what followed.

The Clip + is almost too small to destroy, and it has the added advantage of using a mini-USB connection rather than the proprietary cord for the Fuze. Since you don’t care about video, it would be great for what you need from a player.  

Well, Black Rectangle, I finally received the cord I ordered (don’t EVER buy from Skque through Amazon—they’re very unhelpful and slow), but I’m still getting the “USB Device not recogtnized” error. Rats. Looks like a new Clip+ is in my future, though I hate to lose my beloved Fuze! It still plays fine, just won’t get recognized by Windows, and now we know it’s not the cord. That’s why I posted—it was actually working fine for listening, so I hoped it was some sort of fixable Windows error.  Thank you for all your help, and your patience!

Well, sorry about the cord…is it still charging?

You could always  get a microSD adapter, connect that to the computer (or pop it into the slot for most current computers)  and load music onto the card, then stick the card in the slot. If it’s a card you haven’t already been using on the Fuze, Format it to FAT32 with Windows first.

If you have copies of your music elsewhere, you might also go nuclear. Take out any microSD card and go to Settings/System Settings/Format and format the Fuze. That erases all the content you’ve added, and sometimes it unscrambles the tiny little brain of the Fuze too. It’s a long shot, but it might fix the “not recognized” problem.

Didn’t even think about the SD slot. I do have an adapter, but don’t have a micro SD card (only regular SD and xSD) but can get one cheap. It’s a thought.

I don’t think I can format the Fuze if Windows doesn’t recognize it! That’s the whole problem. Windows doesn’t see the hard disk in it.It shows “connected” but there’s the error message in the title, and it doesn’t show up in Explorer.

@hecate wrote:


I don’t think I can format the Fuze if Windows doesn’t recognize it!

There’s a FORMAT option in Settings > System Settings on the player. It can format itself without the need of a computer.

Kewl! Will try that. As grandma used to say “couldn’t hurt”. (Well, it could if you lose files, but at this point, I’m going to lose them anyway, and I have most of the music and playlists on my computer.)

Yes, formatting will erase all user-added content. so you will have to re-load the player from the files you have backed-up on your computer.

The below solution is workingf for me, 

So try it, may be it works for you too,

Solved: USB Device Not Recognized In Windows

Any body have the working solution?? https://www.wiknix.com/usb-device-not-recognized/

not working for me. https://support.microsoft.com/en-us/kb/2654149

Solved: https://www.wiknix.com/usb-device-not-recognized/