USB Device Not Recognized


We have a 4 GB Fuze. My wife uses it several hours each day and truly like it. However, two of them have failed. The first lasted about 9-10 months before we experienced an unrecoverable “USB Device Not Recognized” problem. The replacement lasted about six weeks before we had the same problem. While SanDisk has been very good about replacing the devices, this is rather frustrating.

Can anyone offer a suggestion as to the cause of the problem and what we can do to avoid similar problems in the future? Is it possible that the problem is occurring due to the use of a wall-mounted USB charger?

p.s. Juts to be clear: I have tried MSC vs MTP mode. I have tried two computer: one XP the other Win7. I have tried the MTP Porting kit. I truly believe the problem lies within the Fuze, but I do not know what is causing the problem to occur.

Message Edited by groston on 07-19-2010 11:50 AM

I’ll just throw this out as a sugestion, is it possibly the usb port it’s self?  I have a port on my netbook that is a little “sloppy” and the cable needs to be inserted fully and straight or I get the “not recogized” warning. A rare ocurance, but it does happen. Especaily now with Win7

Sounds like you might have an intermittant USB cable or a bad USB port.  Remember, do not use an Ipod USB cable.

It could, of course, could be the Sansa – but, two with the same problem? … unlikely.