updating clip+ firmware has caused disc to be "unformatted"

I have been having problems with my clip+ switching off and  sometimes not connecting properly to the PC for recharging. I was advised to update the firmware manually [as the firmware shows up to date] When I tried to drag the .bin file  H: [the clip +]to the clip+ it hung. I waited 30 mins in case it was slow copying the file. Now windows explorer reports that the  H: disc is not formatted. and later when I tried to open the device with windows explorer, windows explorer reported " H: is not accessible. The request could not be performed because of  an io device error". I do not know where to go from here. Any help appreciated.

 The device is still under warranty. Where do I return it . It was bought from  via Amazon from 

Online Commerce Ltd.


Follow up. I have tried various options, such as resetting by pressing the power switch for 20 secs. This time it has not helped


I would contact SanDisk customer service about the issue, and possible replacement.  In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:  http://www.sandisk.com/sandisk-support/contact-us.