Unovercomable problem??

Ok, I have appeared to have run into some kind of unovercomable problem with my 2G Sansa Clip. I have browsed the forums and tried various things but have not managed to find a solution. So I’m kinda hoping some bright genious here might be able to help me out.

I have run into the good old “refresh database error”. But not only that, the Sansa Clip all of a sudden is also not being recognized anymore by my PC and is no longer showing up in windows explorer.

I have tried a soft reset a dozen times…no results

I have tried mounting it in MSC Mode ( turned it off, set it on hold, connected it again holding centre button )…no results

Tried on different PC’s…no result

So basicly there appears to be no way to enter it…

Anyone any ideas…?? :cry:

Make sure the Clip is well charged.


Try a different USB cable.


Try harder at getting it connected to the PC.   There are steps to try,  the best troubleshooting guide to this is found here:


Yes and try another computer,   preferably a windows XP system. 


If you are successful in getting it connected,  do a format on the Clip from the PC.    Then  perform the format again on the clip’s menu:   Settings > Format > yes.        This will set the correct cluster size to 32k.


You may want to reinstall the firmware, if you are successful with the above.


Good Luck,


tried all of the above but to no avail :cry:

Clip gives fully charged, tried 3 different USB cables, on 3 different PC and tried connecting them to differents ports. Went through the trouble shooting guide step by step but without any results.

The odd thing is really that it worked quite fine on this PC, till I got the “refresh database” problem.

I think only remaining options is either throwing it in the bin or seeing if I can have it send back :neutral_face:

Thanks nonetheless Niko

:(   Call Sansa Supports phone number, I don’t know if they have any magic,   but its the only thing else I can recommend.   Sorry I couldn’t help you.   maybe someone else will chime in, to help.