Unable to transfer anything to sansaclip

I am currently unable to load anything to my sansaclip.  The window was saying “device has been disconnected or has stopped responding”.  Now I just get the download progress bar and it stays motionless with no progress forever.  I have not had this problem until recently.  I tried resetting the whole thing and that didn’t work.  The device is connected properly.  I tried using different usb ports and cords.  I tried many different files.  I tried resetting the whole thing and that didn’t work.  Now I have a player with no music and I am unable to put anything on it.  I’ve also downloaded the most recent firmware except I’m not sure that it worked because after I download the firmware I get a message from the firmware downloader software saying that there are still new updates to be downloaded.   ??

If you have the original Clip, then it is time to get a new player.

 If you have a Clip+ or Clip Zip, you could put music on a card using a USB card reader, then put the card in the player and see if it will play it. As long as you can charge the player with an AC usb charger, and music on a card will play, then the player is still useful.