Unable to save a file to a new USB drive

I have just purchased a Ultra Fit 128GB USB 3.3 Flash Drive, the first file I have tried to save it is a Microsoft Money backup file,

It seems to backup Ok until I get a message as follows

"Money has filled the current disk.

Please insert Backup Disk 2 into the E:\ drive so that we may continue build your backup." (without quotation marks)

When I click on OK the backup completes and when I check file manager it has created 2 files

The first is only 1623MB and the second 1MB

The files saved end in ****2015 d1.mbf and ****2015 d2.mbf

There are no other files on the disk at the moment, I have tried re-formatting it but the problem still exists

Any suggestions?

1 Like

Are you using microsoft money 2007 or earlier? If so it looks like the issue is with the application and you can only use disks smaller than 2GB to backup. See the link below for more info. 


I’m using MS Money V14, not sure of the year

I am already using a San Disk 32GB Ultra Fit USB to back up, and previousley used HP & Kingston USB’s betwem 8GB & 32GB for backups and have not had any problems

The link you have provided doesn’t work, although I have found other references to backups on the same site

maybe this link will work


Problem solved by installing the free MS Money Sunset edition

Thanks for the replies