Unable to format Extreme Portable SSD V2 on MacOS Monterey

Formatting gets stuck at “Creating partition table”. Tried 2 different 4TB Extreme Portable V2 drives, same problem. Works fine on Big Sur. Contacted Apple and they said Sandisk needs to fix their firmware. Tried contacting SanDisk support but got frustrated with how bad it was and gave up pursuing the problem with them.

1 Like

I just came here to post the exact same thing. Were you able to resolve the problem? Or did you just return the drive?

No resolution. Apple blamed Sandisk, Sandisk just said the drive wasn’t yet certified for use on Monterey. I returned the drive & will probably stick with Samsung in the future (their drives seem to work fine on Monterey).

1 Like

Any update from Sandisk? I have a 4TB Extreme Portable V2 now that I can’t use… I contacted support, Sandisk support said they are working on it but no more updates…at least give us a lead time please.

No sorry, I gave up and returned mine.

I just got the 4 TB Sandisk Extreme Pro too. I was pulling my hair out earlier. It is just not do able. I will try to format it on some other computer and see if that works

It’s not worth the hair loss! I was able to format the drive on Big Sur as APFS, after which is seemed to work on my Monterey machine, but I’ll probably return it anyway because at some point when don’t have a Big Sur machine I’ll probably need to format again - plus I don’t fully trust a drive that won’t even format on a given OS.

I was able to format a 1TB Extreme V2 on Monterey 12.0.1 to APFS. This was on a 2018 15" Macbook Pro. I also have Tuxera NTFS installed for NTFS use, but formatted this via Disk Utility and it formatted from exFAT to APFS in under a minute. I didn’t choose any of the encryption modes etc.

For the people having trouble, are you guys on M1 or Intel?

There’s a temporary solution. You can use a USB 2.0 usb c to usb c cable.
For example the USB charging cable that came with Macbook Pro prior to M1 magsafe cable.
Use that USB 2.0 speed C to C cable connect your Sandisk portable SSD to the Monterey Macbook pro and erase the partition to APFS. It will work.

After the erase process complete, you can switch back to use those fast 10Gbps USB C to C cable to connect the SSD and it will read/write normally and at full speed.

1 Like

Thank you so much, darkinners, for your work-around solution. That is, indeed, what did the trick, for me. I thought I was going crazy because I just couldn’t get my M1 Mac to format the SSD via the included USB C cable. However, when I used the USB C to USB A adaptor and plugged it into a connected hub, it formatted to APFS lickety-split. Very strange, for sure. I was so happy that I had to create an forum account so I could thank you. :blush:

I tried everything. Then I did a chat with Sandisk: Live Chat Live Chat

Leo A.: SanDisk has not tested SecureAccess on the latest operating system Monterey since it has recently been launched.
Leo A.: The information has been shared with our developers so that they can fix it at the earliest.
Leo A.: If possible please try to use the drive with older macOS to access the data.
Leo A.: We will be updating our support website with latest information as it becomes available.
Leo A.: Right now we not have any update from the developers about the SecureAccess compatibility with Monterey.
Leo A.: We apologize for any inconvenience this interruption may have caused.
Leo A.: I understand the situation is perplexing but believe me, we do understand that the data is the most important to you. Hence, our engineering teams are actively investigating this issue to try to find a resolution.
Leo A.: We will be updating our support website with latest information as soon as it becomes available.
Leo A.: We will update you once we have the update available.

I have exactly the same issue. After I downloaded the Monterey macOS update my Extreme SSD 1TB has stopped working, the system gives me the same alert as mentioned above.
I really beg SanDisk to urgently update the firmware, so that I can use the hard drive as soon as possible, I really need the data for an important exam.
How long do we have to wait for this urgent update?
Thank you for your respones!

In my case the drive makes Finder crash. Only solution is to force quit it and restart, sometimes forcing shut down via power button.

The question here is how long Sandisk will take to work around this issue. It’s completely unacceptable that this is running for more than a month with no resolution. Really poor costumer service.

As I would have liked to known, from what i can tell, this may be possibly resolved with the Mac OS 12.1 update. I was also previously unable to format this disk in Monterey, and had to format it on an older OS. Even after that, it still did not behave as expected. After this update, it appears to be working. If other can confirm as well, would be helpful.

So far, formatted the disk, partitioned it, reformatted, in both APFS and Mac OS Ext. All seems to work, where none did before.

Same experience with 12.1, formatted disk in seconds

I am on a 2017 iMAC, intel based. A new 4 TB SD SSD will not format to APFS using OS 12.0.1. This using either the supplied C to C cable or using the supplied adaptor to USB A 3.0. Interestingly, I did a speed check and speeds were as follows. C to C through a LG monitor. The monitor connects to the iMAC through TB 3.0. Write 319, Read 352. Then connected to computer USB 3.0 A port. R=428 W=429. Any ideas why the C to C should be so slow. Heck, they both are well below the 1000MB/sec as advertised.

I was able to format my 4 TB Extreme Portable SSD finally on Monterey 12.1. It look longer than I expected (maybe 10 seconds) but it did complete. So, seems to be working OK now.

I was able to follow the instructions of killing fsck and then running First Aid through the Disk Utility on MacOS Monterey 12.1


Seems to be a major problem with Monterey. SSD which worked fine under Big Sur now won’t mount and cannot be erased with Disk Utility.

Apple seems to have fixed this issue with Monterey 12.2.

I got a SanDisk Extreme SSD (v2) today and encountered the same problem with Monterey 12.1 on my M1 Mac. Disk utility wouldn’t reformat the SSD at all, but worked perfectly after the Monterey 12.2 update.

1 Like