unable to access Private Folder on Mac ( SanDisk Extrem PLus (SDHC UHS-1 card)

I am trying to watch videos i recorded with my camera (a Sony XAVC 4K)on my Mac (OS X 10.8.5)

the computer reads the SD Cards but i can’t visualise the folders

there is no icone and it only reads “PRIVATE” under (where the folder should appear 

The card was formated on my camera (a Sony XAVC 4K) again and again

sometimes the folder “PRIVATE” appears and i can access the videos

but once i try to record other videos, and read them on the mac,  only have the ghostly “PRIVATE” sign

then i have to format the card again (and lose all the videos on it) and record again

it’s hell !

The card is formated in FAT 32
i can read the videos on the camera player, 
please help
thank you


does the card still show the capacity as used?

have you tried connecting the card to any other computer? If so same result?

do the videos still show normally when you browse the card using the camera?

Do you have similar issues with any other cards?