Trying to sync my Sansa e260 to Windows Media Player

My Sansa e260 will start syncing with the internal drive, but when I try to sync with an external micro SD card, it says: “Windows Media Player can’t open the file.”  What should I do?

Why sync? Just drag & drop (copy & paste) the files from your computer to the card. Easy-peasy. :smiley:

Oh…so just bypass the Sansa mp3 player and just stick it on the microSD card?  Eliminate the 'middleman"!  Didn’t think of that, Tapeworm!  I’ll give it a try.  Thanks! :smiley:

No, what I am saying is bypss Windows Media Player. It’s not needed (and often creates more problems than it solves). You can drag & drop content to the player as well as the card. Forget about MTP (USB Setting) and just use MSC Mode. And NEVER use Auto Defect.

I didn’t use WMP, however, I did insert the Micro SD card into my PC and made the music files “send to” the card.  Tried it again in the Sansa…and it doesn’t even recognize there’s any external card.  Maybe the Micro SD card reader in the Sansa is bad?

I’m confused then . . . you said you “synced” your player. This involves WMP or other software.

If you have your player set to MSC Mode, when you connect to your computer, 2 new drives will show up, each with their own drive letter. One is the player’s internal memory; the other is the card (slot). If you are using the “Move To” or “Copy To” command in Windows Explorer, make sure you are navigating to the correct “drive” (the card) when directing where the files are to be copied or moved to.

Yeah…I tried it another way after trying to sync my player with WMP.  And it still doesn’t work.  I think that the Micro SD card reader might be bad on my Sansa.   It’s a shame, since I’ve hardly taken the card in and out of the player.  I don’t know why it would be worn out already…

I was also wondering, Tapeworm…does the e260 have the capability to handle a 32GB or 64GB microSD card?

32GB? Yes. I have one in my E280. Works flawlessly. The only caveat is that there is a database file limitation which you’re likely to hit or exceed since when this player was designed and brought out the largest MiscroSD card was only 2 or 4 GB.

64GB? Only if you re-format the card to FAT32 instead of its native exFAT configuration. But again, you’re likely to hit the database limitation with only a 32GB card, so you definitely will with a 64GB one.

Now, when I try to sync with my 32GB card, it says:

Windows Media Player cannot access the file. The file might be in use, you might not have access to the computer where the file is stored, or your proxy settings might not be correct.

It used to sync just fine before…so I don’t know why it won’t now.  Any suggestions?

@chrismar111 wrote:

Now, when I try to sync with my 32GB card, it says:


Windows Media Player cannot access the file. The file might be in use, you might not have access to the computer where the file is stored, or your proxy settings might not be correct.


It used to sync just fine before…so I don’t know why it won’t now.  Any suggestions?

Again, why are you continuing to use WMP and trying to ‘sync’? :confounded:

It could be that you are trying to transfer ‘protected’ content. Are these mp3’s or wma format? If you used WMP to rip CD’s you own, note that the default ripping settings in WMP are for ‘protected’ (DRM-encrypted) .wma files. You have to change the settings to make it rip in .mp3 format. DRM encryption prevents copy-righted audio files from playing in other devices (like your player). Mp3 files are not copy-protected.

Or possibly, as you suggested before, the card slot may indeed be defective. Do you have a card reader? If so, I’d try plugging the card (in the card reade) into a USB port on your computer and transferring the music over that way. it’s simply copy & paste, like you would do with any file on your computer, moving it from one location to another; only in this instance you’d be copying the files to a different drive (the card).

If you don’t have a card reader, I’d get one (or two, for sometimes the cheaper ones fail with no warning or reason). They’re very inexpensive. If the songs you transfer to the card still won’t play, it’s likely the card slot/reader in the player is bad. In that case, there’s really nothing you can do about it, except just use the internal memory or get a new player.

Again, I’m using WMP to sync because it worked before.  I’m just baffled as to why it won’t now.  By the way, the Sansa mp3 player I have only has a “format” function…not a “USB Mode” selector as the earlier e260s had.  I just bought a new e260 off of e-bay…and the microSD card doesn’t seem to work in that one either.

Oh…and I do have a card reader built in to my PC.  I dragged music onto the microSD card with my PC.  The Sansa indicated that it HAD a micro SD card in the slot when I slipped it in there, but it indicated that it didn’t have anything on the card.

You must have a v2 model with the original firmware. That player (and firmware) was released without a USB mode switch in it.

Follow the directions for manual firmware installation/updating in this post, and you should be in business.

And for goodness sake, lose WMP for transferring files to your player. :wink:

“Failed to download selected files.  Please try again later.”  That is the message I get when I try to use the Sansa Updater.  

According to my device, I have version V03.01.11A

I believe I have successfully downloaded the newest version to my e260.  Now, I just need to see if it behaves any better.  It is still saying that my MicroSD card has NO bytes and NO memory on it.

It’s NOT behaving better.  It still is giving me trouble.  I’m starting to think maybe I should get the newer 4GB Sansa Clip, which has a slot for microSD cards.  It may just actually work the correct way! 

What firmware version is on the player now? If it is still V03.01.11A that is the original flawed firmware I told you about. Do not use the Updater; update the firmware according to the manual instructions in the post I linked to.

Then try formatting your player. There is a FORMAT option in Settings > System Settings. Note this will erase all files you have transferred to it so you will have to re-load your content, but formatting can sometimes solve weird anomalies.

It may indeed be toast, but without any further ‘detailed’ feedback from you on what you’ve done or what is going on, no one can do anything but guess at things to try and help. “NOT behaving better” and “still givinig me trouble” says nothing.

It means that it’s doing the same thing as I expressed earlier…even after the manual update you sent me for V03.01.16A (Thank you for that update!)  My PC says there’s songs on the card, but my Sansa still says: SD Card - 0 MB, Free - 0 MB.  At one point, I thought I had all the songs, but when I tried to play them (it even listed the title and artist) but would just act like it couldn’t find the file and immediately skip to the next song to try and find that file.  It said something about “Sync to continue music subscription…” each time it tried to find a song file.