Trying Media Player 11 fixed Winamp

I am suddenly having a lot of success with MTP mode in Winamp and in Explorer. All I did was try Media Player. I had an old version, so I downloaded the newest version. I still think it sucks, so I went back to Winamp. But now the Sansa, in MTP mode shows up in Explorer. I sent a playlist from Winamp into the Sansa and it shows up under playlists in the Sansa and can be played. In Explorer, I navigated to the proper directory, copied in Folder.jpg and now I can see Album Art. I actually cannot find anything that does not work. It seemed improbable that simply trying WMP would help, so I discounted that at first. But I looked up MediaMonkey since some folks have mentioned it. On the MediaMonkey website, I found this faq article which states:

‘Plays for Sure’ devices require that certain Microsoft libraries be installed on the host PC. These libraries are included with Windows Media Player 10.

In addition, this Wikipedia page states:

Windows Media Player 11’s MTP driver, however, does allow MTP devices to be used almost identically to a filesystem-based devices.

So if you are trouble and have not yet installed and tried WMP11, you might want to give that a shot. I’m not sure if simply installing it is enough. I tried the Sansa in WMP for a while immediately after installing the latest WMP. This could have updated the registry or done something else to associate the Sansa with that MTP “driver”. I hope this helps some of you.