Trouble loading poscasts using wmp11

I posted in the wrong place earlier so am reposting with a new subject:

I recently bought a sansa clip and really like it except I have not been able to transfer podcasts to it.  I go to a site that has podcast available in mp3 and start the download.  Wmp 11 starts playing it and loading the file in the “now playing” heading.

I cannot then do anything with it. 

 I try to drag it to the sansa device to synch but shows a “not available” sign.  I can’t save the file but can play it on the computer.  What am I missing?  I have tried podcasts and/or download mp3 areas from several sites and get the same results.

you need to properly sync it. click Sync, is the Sansa Clip detected? if yes, drag n drop the podcasts under the Sync List (the one w/c says drag items here…) and click Start Sync at the bottom…

make sure you save the podcasts in your computer first before you sync it to the sansa clip

I have not been able to save this download.  I have right clicked, looked in the menus, stood on my head and still can’t find a command to save the file.  I tried dragging to areas on the libraries page… just get the circle with the line through it.

Sorry. my bad!!  Got it!