Transfer of audiobooks

I am trying to use One Click to transfer audiobooks to my sansa clip+.  The chapters appear in reverse order making books very annoying to play.  Please help

I don’t know what One Click is, but your Clip+ is going to sort and play files (audio or audio books) by the information contained within the ID3 tag of the file, not by the file names themselves. You might want to download and use MP3Tag to optimize your book’s tags.

Image Editor won’t run on my PC.  Ruled out by Norton, I think.  One Click is app used by some Public libraries for downloading their books.  

Most libraries use Overdrive to transfer DRM-encrypted audibooks onto portable players, but regardless of the program used the player must be in MTP mode (for the licensing permissions transfer) and the tags may still need editing to play in the correct order.

Image Editor? Huh? The program is mp3tag. 

Make sure you are getting mp3tag from the source.

There’s no malware or anything else in it. Just a tag editor. I have loaded it on many computers with various antivirus software–including Norton on this one, and the even more paranoid Kaspersky on others–and it has never been blocked. if you got  the software elsewhere, then maybe Norton protected you from something. 

By the way, for MTP mode: Settings/System Settings/USB Mode/MTP. If you’re using the default Auto Detect, it may send you to MTP anyway, but better to be sure.