Track numbering on MicroSD Card

My Fuze is playing the tracks in incorrect order in Album mode. But this problem is only present for tracks on my MicroSD card, not the ones in the main memory. When I go to file info, it shows a weird number for track #. For example, in Nine Inch Nails’ Ghosts I-IV, the 1st track, 1 Ghosts I, is stated as track number 136 instead of 1 in File Info, and 2 Ghosts I as track 236, instead of track 2. But it states that the bonus track 37 Ghosts is track 37 so it appears before all the other tracks rather than after them, where it should be.

I use MediaMonkey to tag my tracks.

I doubt it’s the MicroSD card. Try moving Ghosts on the unit, and I’ll bet you’d have the same probem. The Sansa can only read what’s in the tags.

Media Monkey’s tags are from Freedb, and maybe the NIN fan who first put them on freedb was a little…er…confused. Like maybe that person was trying to type 1/36 and typed 136 instead. 

Anyway, you’ll have to change the tags. mp3tag is good, fast and free and it has an Auto-Numbering wizard (use Leading Zeros so you get 01, 02. etc.) 

If you use MP3Tag, you should also set it to save the tags in ID3v2.3 ISO 8859-1 format. That’s the format Sansa players like best. Other formats can cause odd results. Also, “x/y” track numbering can be problematic with Sansas. Simple “01”, “02”, etc. is preferred.

It IS the microSD card. I’ve moved albums with this problem from the SD card to the main memory, and in the main memory the Fuze ordered the tracks correctly. But when I put them back onto the card, the problem just comes back. Also, I checked the files in both Medimonkey and Windows explorer, and according to both, the tracks are numbered 1-37 like they should be, not 136-3636 which is what the Fuze says.

That really does sound like what you get on the Fuze when the track number is set as X of Y, instead of just track X. Mediamonkey would be able to read and understand X of Y track numbers because it writes them, but the Fuze doesn’t. (Did they fix track number handling in the last firmware update and forget to tell us? I’ll have to check when I get home.)

Anyway, it sounds like you have this album set as track X of 36. Renumber them to track X of 37 and it should play in order–the track number on song info isn’t pretty, but 137 < 237 < … < 3737 so it still works. Or remove the of Y part altogether. I stopped setting it when I saw how the Fuze handled it.

Side note: the Fuze sorts by disc number and then track number, so you can label that way, too.

I found the answer to this little problem. When the variable ‘Part of Set’ is different for different tracks on an album, the tracks will be out of order. And like I said, this problem only occurs with tracks on the MicroSD  card, but when you move the tracks on to the main unit the problem disappears. So I just changed the ‘Part of Set’ data.

i lost my memory card.please say how to find it

@senthil wrote:

i lost my memory card.please say how to find it


Although I can’t see how this has anything to do with the subject matter of this thread.