Message Edited by TomJensen on 05-03-2010 05:36 PM

Just tried this today; awesome!

It changed the way I see my Fuze.


This is the greatest program ever.  Thank you, SMC has been driving me crazy. Using the drop feature is so easy.  This even transcodes .flv files!!!

Message Edited by mh7719 on 04-03-2010 02:09 PM

It would be extremely nice if this wasn’t hardcoded to C:\Vidz, especially since we haven’t been running DOS for the past 15 years…

What’s keeping you from using relative paths?

I tried it on a random video from youtube that I downloaded with the DownloadHelper Firefox plugin, and it worked perfectly. Rock on!

Message Edited by TomJensen on 05-03-2010 05:36 PM

Nice update, I’ll give it a go later on. mencoder is some pretty powerful software, it can do what you listed. FuzeVidz is by far the best video converter I’ve used for the Fuze.

Since the script is intended for regular users who don’t know or care what IVTC means, any function has to be auto. Manual crop/IVTC/deint are straightforward on mencoder, but if you know of any mencoder/ffmpeg script to auto-detect IVTC or deinterlace, please drop me a note.

Probably more useful is if I can find a forum or list that specializes in mencoder/ffmpeg, like Doom9/10 is for x264.

For autocropping, the normal strategy is to run the autocrop command for a couple seconds each on, say, 10 different spots in a movie, then run a fuzzy ceiling function on the results. But on mencoder, seeking is partially broke; it doesn’t work on some media like MPEG2, where it’s needed most.

Cropping isn’t really needed for the Fuze, since the image is letterboxed to 4:3 anyway. But would be nice to have for screens that don’t require letterboxing.

Auto functions have been done on AVISynth, which has a vastly larger repertoire for video processing. I think I’ll eventually resort to it as a wrapper before feeding to mencoder.

BTW, x264 has recently incorporated lavf, so it can handle the same wide variety of input media as mencoder. It still doesn’t do audio or muxing, or basic image processing like mencoder/ffmpeg, however.

nice freakin software. woks well converting the files and using the sansa converter software… good stuff guys

Message Edited by TomJensen on 05-03-2010 05:36 PM

Love the “rotate” option.

Right now, it seems to be set for rotate AND flip, which means text comes out backwards.  

Is it possible just to rotate the image 180 degrees and not to also flip the image side to side?



Oops. Fixed for next iteration. Thanks for the catch.

To fix it yourself: Load the script into Notepad, search for all instances of “,flip” (sans quotes) and replace with “,rotate=1,rotate=1” (sans quotes). Note the commas and no spaces. There should be three such instances.

Message Edited by TomJensen on 04-15-2010 10:39 PM

Thanks for the quick fix.

My editor found all three instances and changed them.

The text is still reversed in the output file, still flipped.

No hurry from me on the fix.  Thanks for the effort; it’s a great tool.

Message Edited by TomJensen on 04-10-2010 03:09 PM

You are right; I am wrong.

I had two copies of Fuze_CONVERT.cmd, one on my desktop, as suggested.

I didn’t use the corrected one.

I changed both, and it works great.


The extra modes (full-screen, 16:9, pan-&-scan) were originally implemented with the idea to enlarge viewing area at the expense of some AR distortion and cropping. The Auto-scale mode subsumes this capability and does a better job of it, so I’m removing these modes by the next iteration per the KISS tenet.

The full-screen & 16:9 modes will be removed for sure, but I’m on the fence regarding P&S. If you want P&S kept, and can present a compelling argument (“I want it” isn’t a compelling arg) for its retention, let me know.

Message Edited by TomJensen on 05-03-2010 05:37 PM

After I do the drag-drop onto the Fuze, why do I get the message, “Unsupported Media Format”?

Message Edited by TomJensen on 05-03-2010 05:37 PM

Ok, I did that.  Uninstalled everything, then downloaded from the link on first page.  Error message comes that it cannot locate needed tools in c:\vid.  Check install.  Not sure how to check install.  I did delete it and downloaded again and same error. 

I also tried the other updated fuzevid and after it was finished converting the video it would give an error message (don’t recall what it said so I just uninstalled that and came back to this one).