the updater cannot recognize my Sansa E140! What can i do?

the updater cannot recognize my Sansa E140! What can i do?

the updater doesn’t support the e140