The player isn't recognized, can't install and EVERYTHING IS FAILING

I get the messages - cannot start this hardware - code 10 USB mass storage device. Tried to use a different port, tried to hold down buttons - I’ve got it connected and it says CONNECTED but its been over half an hour and its not charging. It’s not showing on Device Manager. Whatever - I can’t get this to work and I don’t want to use WMP at all. Is this a prerequisite to use Sansa? I just spent my good money on this player. Please someone help.

Code 10 is a Windows error message. Here’s a link to a solution in a thread here on the forum. Hope it helps. This was from a Clip user too.

Tip: In the future, try typing your error msg. or problem into the ‘Search’ box here. That’s how I found it. :wink:

Try changing your USB settings to MSC.

On the player go to 


Thank you:neutral_face::dizzy_face:::smiley:

It recognized it by switching to the other USB mode on the device itself.

Now - is there anything else I need to know - for example - unlike my other sansa express (which died) it’s not giving me any indicator how much is charging - if it’s charged or what. I have a feeling that I left in the express too long in the USB, mistakenly booted with it still in the USB port and ultimately fried it. Could this be the case? Could this happen again? 

Please tell me what else I need to be knowing.

Sheesh. Thanks again for the help.

It cant overcharge.

please upgrade your firmware if you havent already.

Charge the device for about 3 hours initially.