The Clip ONLY Charges

I have a 4gb Sansa Clip, and two months ago, it stopped working correctly. I’ve let it sit around, thinking I’d just throw it away since it doesn’t work. But now, I want to see if I can fix it.

The problem:

   Every time I plug it in the device charges, and the battery icon shows it doing so. However, the screen doesn’t go to the “transferring” screen like it should when plugged into a computer. So I cannot view or write the files on the computer. I have a 1gb model that works fine with my laptop, so I know it’s the specifc 4gb model.

     I’ve tried:

            - Different USB ports, cables and different computers.

            - I’ve tried to put it into MSC mode, but I can’t get it to even do that. It just continues to ONLY charge.

            - I’ve even reformatted and reset all the settings.

            - I’ve tried to update firmware, but because the computer doesn’t recognize the Clip I can’t. 

I’ve read through a lot of forum posts, but I still can’t find an answer. Does anyone know how to fix it?

Thanks a lot,

WiteCastle

Have you tried forcing MSC mode to connect?  Turn the Clip off and put it in locked position (on switch all the way down); and then hold down the center button as you connect the USB cable between the Clip and your computer.  That sometimes will work where a connection otherwise doesn’t.

How about a reset? (NOT the same as “reset all” from the menu)

Hold the power switch in the “on” position for ~20 seconds before releasing it. Then power on normally and try to connect.

Yeah, I just tried both of them. Neither one worked.

Is there anything you can do with a broken Sansa Clip, other than throw it away?

Don’t give up yet. It might be a driver problem. If you’re using Windows, go into Device Manager (Windows key+Pause/Break) and look for malfunctioning device drivers in the “Universal Serial Bus controllers” section. Bad devices are indicated by a yellow triangle & exclamation point icon. Right-click and delete all the bad ones, then reboot your computer. Once Windows finishes restarting, connect your Clip again and Windows will reinstall the driver.

Thank you, but all my USB hubs on all my computers are working fine. The thing I don’t get is that, the Clip charges, but it just doesn’t show a “connected” screen at all.

My next thought would be the cable, but you said you’ve tried different cables. How long have you had it? The warranty (in the US, at least) is one year. If it’s still covered, call Sandisk and they’ll replace it.