System XP SP2 2GB Clip not recognized

I have a Sansa Clip 2GB Black that is not recognized by the system.  I have tried uninstalling and re-installing, loading USB storage drivers and get a type 10 error. I know that for the clip to be updated that I have to be in MSC mode. There is no way to change modes on this Clip, that option is not available in system settings. There must be some hardware way of changing it to MSC mode manually, so it can be updated. Otherwise this just a useless piece of plastic and chips. I know that the system sees the clip, it just refuses to recognize it. By the way, I have Media version 11 on the computer.

 If anyone can help that would be great, otherwise it goes to the recylcling center and I’ll never buy another Sansa MP3 product.

Well all, I figured it out and it works great now, but only in MSC mode. Windows media player 11 will only recofnize it in MSC mode. But it works so great!

Thanks all who would have gladly helped!

R60060

It sounds as if you have an earlier firmware, from a few generations ago. The latest firmware, version 29, as well as the last few allow the USB mode to be selected, under Settings/USB.  I would update to the most recent–see the sticky thread at the top of the forum for the firmware and instructions.

Also, firmware indeed can be updated under MTP mode, not just MSC.

Perhaps this will help you.

after spending more thand 10 hrs looking  for a solution for my 2gb unrecognized sansa clip on sp2 and sp3 BUT it was recognized by vista ,and after reading tons of internet solutions and forums ,the only solution (which worked for me) plug the sansa to pc with vista os and make sure you have the latest firmware if not please upgrade to the latest ,then choose setttings/usb mode/msc…its finally recognized by windows sp2 but not as a mp3 BUT as storage device

however,i missed 2 features  at this solution 1-the sansaclip would  no longer charges from the computer (usb charging)instead  u could get a charging adapter from amazon which i did long ago.

2-i miss the sansa icon at the right corner which i really likes

instead of all that install windows vista which is a genie device recognizer

if any help plz contact me omran.mohamed@gmail.com

once i had the same problem(on my XP SP2). the problem is that MTP protocol driver installs unpropertly…

There were 2 ways to solve the problem -fully reinstall Windows or try to fully reinstall WMP 11 (the last didn’t helps me)

I desided to install Vista SP1

Message Edited by feromon on 10-21-2008 12:50 AM

try this 

-Make sure you are logged in as an administrator

-Open your command prompt (Start->Run->“cmd”->press Enter)
-Type the following:

Net localgroup Administrators localservice /add

Reconnect your device. 

Fixed thanks Bob

Message Edited by drlucky on 10-21-2008 11:07 AM

There should be no space between local and service, it’s “localservice” in this command.

Bob  :wink:

Thanks so much guys, the net command resolved the problem I was trying to fix (forced MSC mode and would get “USB Device Not Recognized” message upon connecting).

How exactly does that particular command address the problem?  It looks like it added a new(?) user to the administrators group - why was this necessary?

I’m just very curious about this - thanks again!