Synchronizing with Amarok - c240

    I’m a Linux user, and as you may know, Amarok is one of the most popular music apps on this system. The problem is that when I try to synchronize my c 240 with it, the result vary from bad to worst. Anybody have had the same problem? Other issue is that is not a dedicated plugin for Sansa player on Amarok, which I think it’ll be really helpful for the users. I’m not a programmer myself, but I think that the guys at Sansa could do it without a problem, the guide to do it it’s here

I think that Linux users deserve the same dedication that Win users. And will be great to have support.


the thing with linux is that its all about being custom. Its hard to help people when every machine is as custom as a linux one can be. Most people who know enough to run linux and get things working dont usually need much help with working a simple mp3 player.

Thank you very much for your help.

In this forum are aprox. 5000 requests of help. And I don’t think that “get yourself some help as long as you’ve been able to turn on a computer” Is the right attitude.

So, anyone with some real knowledge eager to help?


lol, I apologize for the way it came off, with the word “simple” in front of mp3 player it made it sound worse then I intended.

I was just trying to get at the fact that if you can install and customize ubuntu and redhat for example, then learning to customize and all that jazz should, hopefully, not be a problem.

Is this an error within the amarok app itself, or is the player itself failing in regards to playback? If im not mistaken, linux doesn’t have mtp drivers (im sure I could be wrong about this) and its used as a removable disk. Just like a flash drive.

Does it let you drag and drop your files without issue?

Ok… I have what can help you at least get the music on your Sansa. Go into Settings > USB on your Sansa. Set it to MTP or Autodetect. Open up your favorite package manager. I used synaptic. Search and install libmtp5, if Amarok didn’t already install it. Now search and install gparted. Connect your Sansa and open Gparted. Your Sansa should come up as a new device. Right Click its first partition. Then click mount on > (whatever option is given). Hit Alt+F2. Type “gksu nautilus /wherever/the/device/is/mounted/” where “/wherever/the/device/is/mounted/” is wherever the device is mounted (lol). GKSU will ask for your root passwork. Put it in and hit enter. This will bring it up in a browser. Go into the directory MUSIC. Drag and drop all your music files there. I hope it works for you

Does it enable MTP in Linux??? @_@

Thank you very much.

I’m sorry for being so late on the answer and for being so unspecific about the issue. Ubuntu auto mounts the sansa C 240 (It takes a little too much longer to detect it but that’s not the issue here) and I can perfectly see and browse the internal memory and the memory card inserted, no root permissions are necessary and I can Drag & Drop files easily. So, that’s not a problem. The Issue Is that when I try to synch with Amarok, and I configure it to manage C240 as a generic audio device, I can’t use it correctly. Amarok recognises the device but when I make a list of songs to transfer to C240 (not a playlist), it fails to do so. I don’t know what it can be, as long as all the rest seems to be going so well.

That’s why I think that a script should be done to make the C 240 and Amarok to get to work  well together.