Suddenly Skipping to next Track of Audiobook


Sometimes, while listening to certain audiobook tracks, my Clip suddenly skips to the next track.  If I back up to the track I was listening to and fast forward to where it skipped, I find that it skips to the next track in the *same place* every time.  For example, I’ll be listening to Track 3, and at 25 minutes and 2 seconds, it will suddenly skip to Track 4.  If I start Track 3 again and listen up until 25 minutes and 2 seconds, it will skip to Track 4 again, every time.  Some  other facts:

-I’ve experienced this problem on 3 different Clips (1GB and 2GB models), all refurbished, but all with the latest firmware loaded (v.35A)

-All audiobooks are downloaded and transferred with Overdrive Media Console, from two different laptops, both running Windows 7

-All tracks are .wma format 

-Most tracks work just fine

-Tracks that don’t work appear to be affected at random; i.e., there’s no way to predict which track will have a problem

-The time at which the track skips appears to be random, but it will be the same time for any given track

-Deleting the file from the Clip and re-transferring it seems to fix the problem for that track

-If I delete an entire book and re-transfer it, I’m likely to get a different combination of tracks with problems; i.e., tracks that didn’t work might start working, and tracks that used to work might start to skip

-I’ve tried reformatting the memory after upgrading the firmware… same issue

-I’ve tried uploading it to the Audiobook folder vs. the Music folder… same issue

If it had happened on only one device I’d chalk it up to a manufacturing issue, but three separate players??  I’m a software developer and diagnose bugs for a living, but this thing is utterly beyond my comprehension and driving me crazy!  



Are you looking at the transferred file sizes?  (Is the file transferring correctly?) 

I’ve experienced this behavior with bad downloads from Overdrive, but the problem was pretty easy to spot by file sizes, so it’s probably not the same thing. 

For the audiobook un-initiated: the .wma or .mp3 tracks should all be about the same size, possibly with the exception of the last track.  If Track 2 is half the size of the rest, it’s a bad download.  Overdrive doesn’t warn you. The partial file plays up to a certain point, then skips to the next tract - very consistently because the rest of the file is simply *missing*.

I have spotty internet connection at home and am basically dependent on public wifi hotspots, so I’ve learned to eyeball the file sizes when they download to delete/redownload the bad tracks, before leaving the hotspot.  I’ve been burned enough times.

Hmmm, very interesting.  I will have to play closer attention to that!  It seems to me that if the problem is that it was not fully downloaded from Overdrive, that re-transferring it wouldn’t fix the problem.  But perhaps I’m mistaken that it does – perhaps I re-transferred it using my other computer, on which it had downloaded correctly.

I suppose it’s also possible that it’s the transfer from Overdrive to the Clip that’s failing partway; no?  I will investigate and let you know what I find.  Thanks for the input!


When you format a player, it should be done using the player’s menu. If a player can’t turn on, then format it using your pc, then disconnect it and format it again using the player’s menu before copying files to it again.

Are these files you downloaded variable bitrate? What bitrate and sampling rate are they?

If a file doesn’t play properly on the player, will it play properly on your pc?

Similar problems on 3 different players probably points to an encoding problem or downloading problem of these files.