Suddenly my Clip+ won't turn on all the way

When I try to turn it on it lights up and gets to the point of displaing the blue “four leaf clover” pattern, but then won’t open the rest of the way.  Also, computer no longer sees it when I plug in USB.  This happened quite suddenly after I charged it from a 220 outlet in Europe, but I’ve done this many times before with no problem.   I tried holding down button for 30+ seconds to reset, but it didn’t help.   Any ideas?  Thanks

Sansa Clip+

  1. Turn device OFF.
  2. Press and hold the center button while connecting the device to the PC.

Keep the player on the same Mode of an hour or 2 then try using the player

If issue still persist Contact Customer support for help or replacement

Thanks, but I already tried that after reading previous posts, and no luck… still stuck on flower logo and computer doesn’t see it.  Any other possible fixes before I contact customer service?

If it’s stuck, won’t reset and doesn’t connect to your computer about the only thing you can do at this point is leave it on until the battery runs down and shuts off on its own. Hopefully once that happens, you’ll be able to plug it into your computer to charge and it will make a data connection so you can re-install the firmware (which should take care of the stuck flower issue). Don’t panic if it doesn’t come on right away though; sometimes it needs to trickle-charge for a little bit before it powers on after a full discharge like this.

Let us know how it goes.

my must have done the same thing 

all of a sudden can not do anything with mine  

same week 

only get the flower 

not seen on computer and have tried pressing buttons and holding buttons

have let battery wear out 

nothing works 

“This happened quite suddenly after I charged it from a 220 outlet in Europe” If that is only for 110V, I think the power system is fried already. Just my opinion though.